diff mbox series

[bug#64965,4/8] gnu: Add ghc-hsopenssl-x509-system.

Message ID 7fff5044b30bf7c4dea217e22d6ad56c90838faa.1690675200.git.me@tobias.gr
State New
Headers show
Series [bug#64965,1/8] gnu: Add ghc-curve25519. | expand

Commit Message

Tobias Geerinckx-Rice July 29, 2023, 11:59 p.m. UTC
* gnu/packages/haskell-crypto.scm (ghc-hsopenssl-x509-system):
New public variable.
---
 gnu/packages/haskell-crypto.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index 4314ad4937..7e1935ece3 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -747,6 +747,29 @@  (define-public ghc-hsopenssl
 implementation of SSL.")
     (license license:public-domain)))
 
+(define-public ghc-hsopenssl-x509-system
+  (package
+  (name "ghc-hsopenssl-x509-system")
+  (version "0.1.0.4")
+  (source
+   (origin
+     (method url-fetch)
+     (uri (hackage-uri "HsOpenSSL-x509-system" version))
+     (sha256
+      (base32 "15mp70bqg1lzp971bzp6wym3bwzvxb76hzbgckygbfa722xyymhr"))))
+  (build-system haskell-build-system)
+  (inputs
+   (list ghc-hsopenssl))
+  (properties '((upstream-name . "HsOpenSSL-x509-system")))
+  (home-page "https://github.com/redneb/HsOpenSSL-x509-system")
+  (synopsis "Use the system's native CA certificate store with HsOpenSSL")
+  (description
+   "This package provides a cross-platform library that tries to find
+a (reasonable) CA certificate bundle that can be used with HsOpenSSL to verify
+the certificates of remote peers.  It is for HsOpenSSL what x509-system is for
+the tls package, and borrows some ideas from x509-system.")
+  (license license:bsd-3)))
+
 (define-public ghc-openssl-streams
   (package
     (name "ghc-openssl-streams")