diff mbox series

[bug#64965,7/8] gnu: Add ghc-vty.

Message ID 18509689167f350b4ced3a6d365b325a93e2205c.1690675200.git.me@tobias.gr
State New
Headers show
Series [bug#64965,1/8] gnu: Add ghc-curve25519. | expand

Commit Message

Tobias Geerinckx-Rice July 29, 2023, 11:59 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-vty): New public variable.
---
 gnu/packages/haskell-xyz.scm | 42 ++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 1db3a157f1..c02fd007f9 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13884,6 +13884,48 @@  (define-public ghc-void
 given term should not exist.")
     (license license:bsd-3)))
 
+(define-public ghc-vty
+  (package
+  (name "ghc-vty")
+  (version "5.35.1")
+  (source
+   (origin
+     (method url-fetch)
+     (uri (hackage-uri "vty" version))
+     (sha256
+      (base32 "062dpz8fxrnggzpl041zpbph0xj56jki98ajm2s78dldg5vy0c9k"))))
+  (build-system haskell-build-system)
+  (native-inputs
+   (list ghc-hunit
+         ghc-quickcheck
+         ghc-quickcheck-assertions
+         ghc-random
+         ghc-smallcheck
+         ghc-string-qq
+         ghc-test-framework
+         ghc-test-framework-smallcheck
+         ghc-test-framework-hunit))
+  (inputs
+   (list ghc-ansi-terminal
+         ghc-blaze-builder
+         ghc-hashable
+         ghc-microlens
+         ghc-microlens-mtl
+         ghc-microlens-th
+         ghc-parallel
+         ghc-utf8-string
+         ghc-vector))
+  (arguments
+   `(#:cabal-revision ("1"
+                       "1zqcvgqhcij92241g20zn3c3a4033biid3f3cqg05q1ygrmznxb5")))
+  (properties '((upstream-name . "vty")))
+  (home-page "https://github.com/jtdaugherty/vty")
+  (synopsis "Simple terminal UI library")
+  (description
+   "vty is a terminal GUI library in the niche of ncurses, intended to be easy
+to use and to provide good support for common terminal types.")
+  (license license:bsd-3)))
+
 (define-public ghc-wave
   (package
     (name "ghc-wave")