diff mbox series

[bug#68481,24/32] gnu: Add rust-rustls-native-certs-0.7.

Message ID 8dce796c423c53ae6a2a2c111ccde98afa18e620.1705346938.git.voroskoi@gmail.com
State New
Headers show
Series [bug#68481,01/32] gnu: rust-anstream: Update to 0.6.7. | expand

Commit Message

VÖRÖSKŐI András Jan. 15, 2024, 7:28 p.m. UTC
* gnu/packages/crates-tls.scm (rust-rustls-native-certs): New variable.

Change-Id: Ic66c11b391be69929d0884a060d9a3bcdbfd3406
---
 gnu/packages/crates-tls.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-tls.scm b/gnu/packages/crates-tls.scm
index fadc4e6888..ec4d6342cd 100644
--- a/gnu/packages/crates-tls.scm
+++ b/gnu/packages/crates-tls.scm
@@ -386,6 +386,37 @@  (define-public rust-rustls-ffi-0.8
     (description "Rustls bindings for non-Rust languages")
     (license (list license:asl2.0 license:isc license:expat))))
 
+(define-public rust-rustls-native-certs-0.7
+  (package
+    (name "rust-rustls-native-certs")
+    (version "0.7.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "rustls-native-certs" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "14ip15dcr6fmjzi12lla9cpln7mmkdid4a7wsp344v4kz9gbh7wg"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-openssl-probe" ,rust-openssl-probe-0.1)
+                       ("rust-rustls-pemfile" ,rust-rustls-pemfile-2)
+                       ("rust-rustls-pki-types" ,rust-rustls-pki-types-1)
+                       ("rust-schannel" ,rust-schannel-0.1)
+                       ("rust-security-framework" ,rust-security-framework-2))
+       #:cargo-development-inputs (("rust-ring" ,rust-ring-0.16)
+                                   ("rust-rustls" ,rust-rustls-0.22)
+                                   ("rust-rustls-webpki" ,rust-rustls-webpki-0.102)
+                                   ("rust-serial-test" ,rust-serial-test-2)
+                                   ("rust-untrusted" ,rust-untrusted-0.7)
+                                   ("rust-webpki-roots" ,rust-webpki-roots-0.26)
+                                   ("rust-x509-parser" ,rust-x509-parser-0.15))))
+    (home-page "https://github.com/ctz/rustls-native-certs")
+    (synopsis "Use the platform native certificate store with rustls")
+    (description "@code{rustls-native-certs} allows rustls to use the platform
+native certificate store.")
+    (license (list license:asl2.0 license:isc license:expat))))
+
 (define-public rust-rustls-native-certs-0.6
   (package
     (name "rust-rustls-native-certs")