diff mbox series

[bug#68481,04/32] gnu: Add rust-aws-lc-rs-1.

Message ID 3fdd63d711d6f2c9baa14c2f8f47fbdb2cd3dabd.1705346937.git.voroskoi@gmail.com
State New
Headers show
Series [bug#68481,01/32] gnu: rust-anstream: Update to 0.6.7. | expand

Commit Message

VÖRÖSKŐI András Jan. 15, 2024, 7:28 p.m. UTC
* gnu/packages/crates-io.scm (rust-aws-lc-rs): New variable.

Change-Id: Ic1f8485ef8524b68b0791eb35c8e47bdea0f637c
---
 gnu/packages/crates-io.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a536866c41..0dc0e6c267 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5381,6 +5381,37 @@  (define-public rust-aws-lc-fips-sys-0.11
 version of AWS-LC.")
     (license (list license:isc license:asl2.0))))
 
+(define-public rust-aws-lc-rs-1
+  (package
+    (name "rust-aws-lc-rs")
+    (version "1.5.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "aws-lc-rs" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1dxsyspw79sxrrdpyq0sxk9ww659cx6zfsbsl3ypqgd56l5amhkv"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-aws-lc-fips-sys" ,rust-aws-lc-fips-sys-0.11)
+                       ("rust-aws-lc-sys" ,rust-aws-lc-sys-0.12)
+                       ("rust-mirai-annotations" ,rust-mirai-annotations-1)
+                       ("rust-untrusted" ,rust-untrusted-0.7)
+                       ("rust-zeroize" ,rust-zeroize-1))
+       #:cargo-development-inputs (("rust-clap" ,rust-clap-4)
+                                   ("rust-hex" ,rust-hex-0.4)
+                                   ("rust-lazy-static" ,rust-lazy-static-1)
+                                   ("rust-paste" ,rust-paste-1)
+                                   ("rust-regex" ,rust-regex-1))))
+    (home-page "https://github.com/awslabs/aws-lc-rs")
+    (synopsis "cryptographic library using AWS-LC for its cryptographic operations.")
+    (description
+     "A cryptographic library using AWS-LC for its cryptographic
+operations.  This library strives to be API-compatible with the popular Rust
+library named ring.")
+    (license (list license:isc license:asl2.0))))
+
 (define-public rust-aws-lc-sys-0.12
   (package
     (name "rust-aws-lc-sys")