diff mbox series

[bug#68481,03/32] gnu: Add rust-aws-lc-sys-0.12.

Message ID 717ed1fb3db0caba4789d759639851ffc59ee9c7.1705346937.git.voroskoi@gmail.com
State New
Headers show
Series [bug#68481,01/32] gnu: rust-anstream: Update to 0.6.7. | expand

Commit Message

VÖRÖSKŐI András Jan. 15, 2024, 7:28 p.m. UTC
* gnu/packages/crates-io.scm (rust-aws-lc-sys): New variable.

Change-Id: I170d66f60a7ec5542822a01089cb63721eebb4c4
---
 gnu/packages/crates-io.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Efraim Flashner Jan. 18, 2024, 7:45 a.m. UTC | #1
We should try to unbundle aws-libcrypto. Generally if the crate has
'sys' in the name and uses cmake its because they're bundling code.

On Mon, Jan 15, 2024 at 08:28:30PM +0100, VÖRÖSKŐI András wrote:
> * gnu/packages/crates-io.scm (rust-aws-lc-sys): New variable.
> 
> Change-Id: I170d66f60a7ec5542822a01089cb63721eebb4c4
> ---
>  gnu/packages/crates-io.scm | 28 ++++++++++++++++++++++++++++
>  1 file changed, 28 insertions(+)
> 
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index f697cea1a7..a536866c41 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -5381,6 +5381,34 @@ (define-public rust-aws-lc-fips-sys-0.11
>  version of AWS-LC.")
>      (license (list license:isc license:asl2.0))))
>  
> +(define-public rust-aws-lc-sys-0.12
> +  (package
> +    (name "rust-aws-lc-sys")
> +    (version "0.12.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (crate-uri "aws-lc-sys" version))
> +       (file-name (string-append name "-" version ".tar.gz"))
> +       (sha256
> +        (base32 "0c93b7gw8r2w2r5s2iqya8n7m75ydn1vh0calb8bxlqvg94zkin2"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +     `(#:cargo-inputs (("rust-bindgen" ,rust-bindgen-0.69)
> +                       ("rust-cmake" ,rust-cmake-0.1)
> +                       ("rust-dunce" ,rust-dunce-1)
> +                       ("rust-fs-extra" ,rust-fs-extra-1)
> +                       ("rust-libc" ,rust-libc-0.2)
> +                       ("rust-paste" ,rust-paste-1))))
> +    (home-page "https://github.com/aws/aws-lc-rs")
> +    (synopsis
> +     "AWS-LC is a general-purpose cryptographic library")
> +    (description
> +     "AWS-LC is a general-purpose cryptographic library maintained by the AWS
> +Cryptography team for AWS and their customers.  It is based on code from the
> +Google @code{BoringSSL} project and the @code{OpenSSL} project.")
> +    (license (list license:isc license:asl2.0))))
> +
>  (define-public rust-az-1
>    (package
>      (name "rust-az")
> -- 
> 2.41.0
> 
> 
>
VÖRÖSKŐI András Jan. 30, 2024, 7:29 p.m. UTC | #2
Hi,

On Thu, Jan 18, 2024 at 8:45 AM Efraim Flashner <efraim@flashner.co.il> wrote:
> We should try to unbundle aws-libcrypto. Generally if the crate has
> 'sys' in the name and uses cmake its because they're bundling code.

I have tried to do that, but failed. It is an optional dependency of
rustls and rustls-webpki, so I just removed it for now in v2 of the
patchset.

Thanks,
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f697cea1a7..a536866c41 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5381,6 +5381,34 @@  (define-public rust-aws-lc-fips-sys-0.11
 version of AWS-LC.")
     (license (list license:isc license:asl2.0))))
 
+(define-public rust-aws-lc-sys-0.12
+  (package
+    (name "rust-aws-lc-sys")
+    (version "0.12.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "aws-lc-sys" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0c93b7gw8r2w2r5s2iqya8n7m75ydn1vh0calb8bxlqvg94zkin2"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-bindgen" ,rust-bindgen-0.69)
+                       ("rust-cmake" ,rust-cmake-0.1)
+                       ("rust-dunce" ,rust-dunce-1)
+                       ("rust-fs-extra" ,rust-fs-extra-1)
+                       ("rust-libc" ,rust-libc-0.2)
+                       ("rust-paste" ,rust-paste-1))))
+    (home-page "https://github.com/aws/aws-lc-rs")
+    (synopsis
+     "AWS-LC is a general-purpose cryptographic library")
+    (description
+     "AWS-LC is a general-purpose cryptographic library maintained by the AWS
+Cryptography team for AWS and their customers.  It is based on code from the
+Google @code{BoringSSL} project and the @code{OpenSSL} project.")
+    (license (list license:isc license:asl2.0))))
+
 (define-public rust-az-1
   (package
     (name "rust-az")