diff mbox series

[bug#68481,32/32] gnu: rbw: Update to 1.9.0.

Message ID 2d5605634f9ce5377f1d748de6403145cb89917f.1705346939.git.voroskoi@gmail.com
State New
Headers show
Series [bug#68481,01/32] gnu: rust-anstream: Update to 0.6.7. | expand

Commit Message

VÖRÖSKŐI András Jan. 15, 2024, 7:28 p.m. UTC
* gnu/packages/rust-apps.scm (rbw): Update to 1.9.0.

Change-Id: Ia3675326ad5a82a6668e10ea19a86cf3cb2f8199
---
 gnu/packages/rust-apps.scm | 14 ++++++++++----
 1 file changed, 10 insertions(+), 4 deletions(-)

Comments

Efraim Flashner Jan. 18, 2024, 7:45 a.m. UTC | #1
Was there something wrong with tungstenite@0.20?

On Mon, Jan 15, 2024 at 08:28:59PM +0100, VÖRÖSKŐI András wrote:
> * gnu/packages/rust-apps.scm (rbw): Update to 1.9.0.
> 
> Change-Id: Ia3675326ad5a82a6668e10ea19a86cf3cb2f8199
> ---
>  gnu/packages/rust-apps.scm | 14 ++++++++++----
>  1 file changed, 10 insertions(+), 4 deletions(-)
> 
> diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
> index 0df46b9b1d..20490ef2ff 100644
> --- a/gnu/packages/rust-apps.scm
> +++ b/gnu/packages/rust-apps.scm
> @@ -1975,7 +1975,7 @@ (define-public watchexec
>  (define-public rbw
>    (package
>      (name "rbw")
> -    (version "1.8.3")
> +    (version "1.9.0")
>      (outputs '("out" "scripts"))
>      (source
>       (origin
> @@ -1983,7 +1983,13 @@ (define-public rbw
>         (uri (crate-uri "rbw" version))
>         (file-name (string-append name "-" version ".tar.gz"))
>         (sha256
> -        (base32 "1p8bzpqgdc20l2vbb80gsb2ri5j16af958bixpnnp73mfvwzxvg1"))))
> +        (base32 "0rlp55kcac9k0rz1zfhyslkfgsim1ka6bkllfzqrayvdfyxqq51i"))
> +       (modules '((guix build utils)))
> +       (snippet
> +        '(begin
> +           (substitute* "Cargo.toml"
> +             ;; Change version requirement for rust-tungstenite
> +             (("0.20") "0.21"))))))
>      (build-system cargo-build-system)
>      (arguments
>       `(#:install-source? #f
> @@ -1999,7 +2005,7 @@ (define-public rbw
>          ("rust-cbc" ,rust-cbc-0.1)
>          ("rust-clap" ,rust-clap-4)
>          ("rust-clap-complete" ,rust-clap-complete-4)
> -        ("rust-copypasta" ,rust-copypasta-0.8)
> +        ("rust-copypasta" ,rust-copypasta-0.10)
>          ("rust-daemonize" ,rust-daemonize-0.5)
>          ("rust-directories" ,rust-directories-5)
>          ("rust-env-logger" ,rust-env-logger-0.10)
> @@ -2032,7 +2038,7 @@ (define-public rbw
>          ("rust-thiserror" ,rust-thiserror-1)
>          ("rust-tokio" ,rust-tokio-1)
>          ("rust-tokio-stream" ,rust-tokio-stream-0.1)
> -        ("rust-tokio-tungstenite" ,rust-tokio-tungstenite-0.19)
> +        ("rust-tokio-tungstenite" ,rust-tokio-tungstenite-0.21)
>          ("rust-totp-lite" ,rust-totp-lite-2)
>          ("rust-url" ,rust-url-2)
>          ("rust-uuid" ,rust-uuid-1)
> -- 
> 2.41.0
> 
> 
>
VÖRÖSKŐI András Jan. 29, 2024, 7:44 p.m. UTC | #2
Hi,

(Sorry for the late reply, I just started to work on this again.)

On Thu, Jan 18, 2024 at 8:45 AM Efraim Flashner <efraim@flashner.co.il> wrote:
>
> Was there something wrong with tungstenite@0.20?

No, I have not tried that version. The .21 version was already
available and I did not want to package the old version.
I completely understand if You prefer the version selected by
upstream, but was not sure about guix policy about that.

Thanks,
diff mbox series

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 0df46b9b1d..20490ef2ff 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1975,7 +1975,7 @@  (define-public watchexec
 (define-public rbw
   (package
     (name "rbw")
-    (version "1.8.3")
+    (version "1.9.0")
     (outputs '("out" "scripts"))
     (source
      (origin
@@ -1983,7 +1983,13 @@  (define-public rbw
        (uri (crate-uri "rbw" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1p8bzpqgdc20l2vbb80gsb2ri5j16af958bixpnnp73mfvwzxvg1"))))
+        (base32 "0rlp55kcac9k0rz1zfhyslkfgsim1ka6bkllfzqrayvdfyxqq51i"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           (substitute* "Cargo.toml"
+             ;; Change version requirement for rust-tungstenite
+             (("0.20") "0.21"))))))
     (build-system cargo-build-system)
     (arguments
      `(#:install-source? #f
@@ -1999,7 +2005,7 @@  (define-public rbw
         ("rust-cbc" ,rust-cbc-0.1)
         ("rust-clap" ,rust-clap-4)
         ("rust-clap-complete" ,rust-clap-complete-4)
-        ("rust-copypasta" ,rust-copypasta-0.8)
+        ("rust-copypasta" ,rust-copypasta-0.10)
         ("rust-daemonize" ,rust-daemonize-0.5)
         ("rust-directories" ,rust-directories-5)
         ("rust-env-logger" ,rust-env-logger-0.10)
@@ -2032,7 +2038,7 @@  (define-public rbw
         ("rust-thiserror" ,rust-thiserror-1)
         ("rust-tokio" ,rust-tokio-1)
         ("rust-tokio-stream" ,rust-tokio-stream-0.1)
-        ("rust-tokio-tungstenite" ,rust-tokio-tungstenite-0.19)
+        ("rust-tokio-tungstenite" ,rust-tokio-tungstenite-0.21)
         ("rust-totp-lite" ,rust-totp-lite-2)
         ("rust-url" ,rust-url-2)
         ("rust-uuid" ,rust-uuid-1)