diff mbox series

[bug#40511,10/10] gnu: Add fava.

Message ID 87zhavs81n.fsf@dustycloud.org
State Work in progress
Headers show
Series [bug#40511,1/10] gnu: Add python-jarco-classes. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Christine Lemmer-Webber April 28, 2020, 7:51 p.m. UTC

Comments

Christine Lemmer-Webber April 28, 2020, 8:22 p.m. UTC | #1
And finally, patch 10 doesn't need any fixes to it, so it's the same as
last time.

That sure was annoying, but at least I learned how to use Magit's "edit"
rebase tool.
diff mbox series

Patch

From 9614e1daf0ca1c43595bf6f1522121874f65b66a Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Tue, 28 Apr 2020 15:39:25 -0400
Subject: [PATCH 10/10] gnu: Add fava.

* gnu/packages/finance.scm (fava): New variable.
---
 gnu/packages/finance.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index c31b87ec19..2553980aaa 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1594,3 +1594,42 @@  generate a variety of reports from them, and provides a web interface.")
     (synopsis "Emacs mode for beancount")
     (description
       "Emacs-beancount is an Emacs mode for the Beancount accounting tool.")))
+
+(define-public fava
+  (package
+    (name "fava")
+    (version "1.14")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "fava" version))
+       (sha256
+        (base32
+         "181ypq2p7aaq2b76s55hxxbm1hykzf45mjjgm500h4dsaa167dqy"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("beancount" ,beancount)
+       ("python-babel" ,python-babel)
+       ("python-bottle" ,python-bottle)
+       ("python-cheroot" ,python-cheroot)
+       ("python-dateutil" ,python-dateutil)
+       ("python-click" ,python-click)
+       ("python-flask" ,python-flask)
+       ("python-flask-babel" ,python-flask-babel)
+       ("python-jinja2" ,python-jinja2)
+       ("python-lxml" ,python-lxml)
+       ("python-markdown2" ,python-markdown2)
+       ("python-magic" ,python-magic)
+       ("python-ply" ,python-ply)
+       ("python-simplejson" ,python-simplejson)
+       ("python-beautifulsoup4" ,python-beautifulsoup4)
+       ("python-werkzeug" ,python-werkzeug)))
+    (native-inputs
+     `(("python-setuptools-scm" ,python-setuptools-scm)
+       ("python-pytest" ,python-pytest)))
+    (home-page "https://beancount.github.io/fava/")
+    (synopsis
+     "Web interface for the accounting tool Beancount")
+    (description
+     "Fava is a web interface for the accounting tool Beancount.")
+    (license license:expat)))
-- 
2.26.0