diff mbox series

[bug#40511,4/10] gnu: Add python-pytest-testmon.

Message ID 878siftmri.fsf@dustycloud.org
State Work in progress
Headers show
Series [bug#40511,1/10] gnu: Add python-jarco-classes. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job

Commit Message

Christine Lemmer-Webber April 28, 2020, 7:48 p.m. UTC

diff mbox series

Patch

From 640ee423f25e1479ae8aa174acd6f1f0530a6325 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Tue, 28 Apr 2020 15:21:16 -0400
Subject: [PATCH 04/10] gnu: Add python-pytest-testmon.

* gnu/packages/python-xyz.scm (python-pytest-testmon): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0a031baac2..062dfe1d2b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19694,3 +19694,25 @@  Open Sound Control 1.0} specification.")
     (description "Python modules for text manipulation.")
     (license #f)))
 
+(define-public python-pytest-testmon
+  (package
+    (name "python-pytest-testmon")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-testmon" version))
+       (sha256
+        (base32
+         "1iasz23zrzjgbak8jiq12i4zmkk8f6dmcdhfxz8m2q03agcidc7x"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-coverage" ,python-coverage)
+       ("python-pytest" ,python-pytest)))
+    (home-page "https://testmon.org")
+    (synopsis
+     "Selects tests affected by changed files and methods")
+    (description
+     "Pytest module for selecting tests affected by changed files and
+methods.")
+    (license #f)))
-- 
2.26.0