diff mbox series

[bug#40511,3/10] gnu: Add python-jarco-text.

Message ID 87a72vtms1.fsf@dustycloud.org
State Work in progress
Headers show
Series [bug#40511,1/10] gnu: Add python-jarco-classes. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/applying patch fail View Laminar job

Commit Message

Christine Lemmer-Webber April 28, 2020, 7:47 p.m. UTC

diff mbox series

Patch

From 5b45a4cd2f10241ddd95e1d761dd9636a4c3cbc1 Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Tue, 28 Apr 2020 15:20:54 -0400
Subject: [PATCH 03/10] gnu: Add python-jarco-text.

* gnu/packages/python-xyz.scm (python-jarco-text): New variable.
---
 gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 54a0ac36bd..0a031baac2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19666,3 +19666,31 @@  Open Sound Control 1.0} specification.")
      "This package provides functools like those found in stdlib.")
     (license #f)))
 
+(define-public python-jaraco-text
+  (package
+    (name "python-jaraco-text")
+    (version "3.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "jaraco.text" version))
+       (sha256
+        (base32
+         "1v0hz3h74m31jlbc5bxwkvrx1h2n7887bajrg1n1c3yc4q8qn1z5"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-jaraco-functools" ,python-jaraco-functools)
+       ("python-six" ,python-six)))
+    (native-inputs
+     `(("python-setuptools-scm" ,python-setuptools-scm)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-checkdocs"
+        ,python-pytest-checkdocs)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-flake8" ,python-pytest-flake8)))
+    (home-page
+     "https://github.com/jaraco/jaraco.text")
+    (synopsis "Module for text manipulation")
+    (description "Python modules for text manipulation.")
+    (license #f)))
+
-- 
2.26.0