diff mbox series

[bug#40511,5/10] gnu: Add python-pytest-watch.

Message ID 877dxztmqy.fsf@dustycloud.org
State Work in progress
Headers show
Series [bug#40511,1/10] gnu: Add python-jarco-classes. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Christine Lemmer-Webber April 28, 2020, 7:48 p.m. UTC

diff mbox series

Patch

From 517253fdc76d5e96ab631e08d6a230c5734f141a Mon Sep 17 00:00:00 2001
From: Christopher Lemmer Webber <cwebber@dustycloud.org>
Date: Tue, 28 Apr 2020 15:21:36 -0400
Subject: [PATCH 05/10] gnu: Add python-pytest-watch.

* gnu/packages/python-xyz.scm (python-pytest-watch): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 062dfe1d2b..d9a972c456 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19716,3 +19716,29 @@  Open Sound Control 1.0} specification.")
      "Pytest module for selecting tests affected by changed files and
 methods.")
     (license #f)))
+
+(define-public python-pytest-watch
+  (package
+    (name "python-pytest-watch")
+    (version "4.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-watch" version))
+       (sha256
+        (base32
+         "1fflnd3varpqy8yzcs451n8h7wmjyx1408qdin5p2qdksl1ny4q6"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-colorama" ,python-colorama)
+       ("python-docopt" ,python-docopt)
+       ("python-pytest" ,python-pytest)
+       ("python-watchdog" ,python-watchdog)))
+    (home-page
+     "http://github.com/joeyespo/pytest-watch")
+    (synopsis
+     "Local continuous test runner for pytest and watchdog")
+    (description
+     "This package provides a local continuous test runner for pytest
+and watchdog.")
+    (license license:expat)))
-- 
2.26.0