diff mbox series

[bug#64137,v2,8/8] gnu: Add catch2-static-3.3.

Message ID 7432e21c6c2f8221afbee755366eb9f74bcd41b9.1687121561.git.david.elsing@posteo.net
State New
Headers show
Series [bug#64137,v2,1/8] gnu: Add mpark-variant. | expand

Commit Message

David Elsing June 18, 2023, 8:53 p.m. UTC
* gnu/packages/check.scm (catch2-static-3.3): New variable.
---
 gnu/packages/check.scm | 11 +++++++++++
 1 file changed, 11 insertions(+)

Comments

Liliana Marie Prikler June 22, 2023, 4:24 a.m. UTC | #1
Am Sonntag, dem 18.06.2023 um 20:53 +0000 schrieb David Elsing:
> * gnu/packages/check.scm (catch2-static-3.3): New variable.
Having an extra package for static catch seems overkill to me.  Since
afaik there are no actual users, you can simply omit this patch, but if
you do have a use case for static catch, I highly recommend going with
the current meson approach, as CMake seems unable to do both_libraries.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 512b2ac070..7986f58cc1 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -623,6 +623,17 @@  (define-public catch2-3.3
 a multi-paradigm automated test framework for C++ and Objective-C.")
     (license license:boost1.0)))
 
+(define-public catch2-static-3.3
+  (let ((base catch2-3.3))
+    (package
+      (inherit base)
+      (name "catch2-static")
+      (arguments
+       (substitute-keyword-arguments (package-arguments base)
+         ((#:configure-flags flags)
+          #~(cons* "-DBUILD_SHARED_LIBS=OFF"
+                   (delete "-DBUILD_SHARED_LIBS=ON" #$flags))))))))
+
 (define-public cmdtest
   (package
     (name "cmdtest")