diff mbox series

[bug#64137,v2,3/8] gnu: Add tsl-sparse-map.

Message ID 56a3a24a9156aac5918076616220ee2cd3228cc2.1687121561.git.david.elsing@posteo.net
State New
Headers show
Series [bug#64137,v2,1/8] gnu: Add mpark-variant. | expand

Commit Message

David Elsing June 18, 2023, 8:53 p.m. UTC
* gnu/packages/cpp.scm (tsl-sparse-map): New variable.
---
 gnu/packages/cpp.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 7878aa2a6d..6f558d1f5b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2623,3 +2623,37 @@  (define-public tsl-hopscotch-map
 a hash set using open-addressing and hopscotch hashing to resolve
 collisions.")
     (license license:expat)))
+
+(define-public tsl-sparse-map
+  (package
+    (name "tsl-sparse-map")
+    (version "0.6.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Tessil/sparse-map")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "0rb7w0hzsj4qbm0dff1niaf75aag9lj0xqhgb3vg5h9hfic62ic2"))
+              (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-cmake-test
+            (lambda _
+              (let ((file (open-file "CMakeLists.txt" "a")))
+                (display "\nenable_testing()\nadd_subdirectory(tests)" file)
+                (close-port file))
+              (substitute* "tests/CMakeLists.txt"
+                (("set\\(Boost_USE_STATIC_LIBS.*") "")
+                (("add_subdirectory\\(\\.\\..*")
+                 "add_test(tsl_sparse_map_tests tsl_sparse_map_tests)\n")))))))
+    (native-inputs (list boost))
+    (home-page "https://github.com/Tessil/sparse-map")
+    (synopsis "C++ implementation of a memory efficient hash map and hash set")
+    (description "This package provides a C++ implementation of a hash map and
+a hash set with focus on memory efficiency.")
+    (license license:expat)))