diff mbox series

[bug#64137,v2,5/8] gnu: Add tl-optional.

Message ID 3a83b2cb978fa59ec7c3b17517f9ea7c77eded28.1687121561.git.david.elsing@posteo.net
State New
Headers show
Series [bug#64137,v2,1/8] gnu: Add mpark-variant. | expand

Commit Message

David Elsing June 18, 2023, 8:53 p.m. UTC
* gnu/packages/cpp.scm (tl-optional): New variable.
---
 gnu/packages/cpp.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index f1d7e89537..2fe7f477ce 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2691,3 +2691,35 @@  (define-public tsl-ordered-map
     (description "This package provides a C++ implementation of a hash map and
 a hash set which preserve the order of insertion.")
     (license license:expat)))
+
+(define-public tl-optional
+  (package
+    (name "tl-optional")
+    (version "1.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/TartanLlama/optional")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0qkjplmhilbi1iqxx3pz0grcx5355ymk6wwd4h4309mk156xgx2q"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-cmake-test
+            (lambda _
+              (substitute* "CMakeLists.txt"
+                (("FetchContent_Declare.*") "")
+                ((".*http.*catchorg/Catch2.*") "")
+                (("FetchContent_MakeAvailable\\(Catch2\\)")
+                 "find_package(Catch2 REQUIRED)")))))))
+    (native-inputs (list catch2))
+    (home-page "https://github.com/TartanLlama/optional")
+    (synopsis "C++11/14/17 implementation of std::optional with extensions")
+    (description "tl-optional is a single-header implementation of
+std::optional with functional-style extensions and support for references.")
+    (license license:cc0)))