diff mbox series

[bug#64137,v2,2/8] gnu: Add tsl-hopscotch-map.

Message ID 68b5dda8fc0b5d59188cda3cf33f0f1537c6efed.1687121561.git.david.elsing@posteo.net
State New
Headers show
Series [bug#64137,v2,1/8] gnu: Add mpark-variant. | expand

Commit Message

David Elsing June 18, 2023, 8:53 p.m. UTC
* gnu/packages/cpp.scm (tsl-hopscotch-map): New variable.
---
 gnu/packages/cpp.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Liliana Marie Prikler June 22, 2023, 4:18 a.m. UTC | #1
Am Sonntag, dem 18.06.2023 um 20:53 +0000 schrieb David Elsing:
> * gnu/packages/cpp.scm (tsl-hopscotch-map): New variable.
> ---
>  gnu/packages/cpp.scm | 35 +++++++++++++++++++++++++++++++++++
>  1 file changed, 35 insertions(+)
> 
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index 5a6298fc4d..7878aa2a6d 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -2588,3 +2588,38 @@ (define-public mpark-variant
>       "MPark.Variant provides the C++17 std::variant for
> C++11/14/17.  It is
>  based on the implementation of std::variant in libc++.")
>      (license license:boost1.0)))
> +
> +(define-public tsl-hopscotch-map
> +  (package
> +    (name "tsl-hopscotch-map")
> +    (version "2.3.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/Tessil/hopscotch-map")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +               
> "012pw37w000pdxdvps0wsqrw6597cm6i6kr5rpl303qmiwqicb2p"))))
> +    (build-system cmake-build-system)
> +    (arguments
> +     (list
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-after 'unpack 'patch-cmake-test
> +            (lambda _
> +              (let ((file (open-file "CMakeLists.txt" "a")))
> +                (display
> "\nenable_testing()\nadd_subdirectory(tests)" file)
> +                (close-port file))
> +              (substitute* "tests/CMakeLists.txt"
> +                (("set\\(Boost_USE_STATIC_LIBS.*") "")
> +                (("add_subdirectory\\(\\.\\..*")
> +                 "add_test(tsl_hopscotch_map_tests
> tsl_hopscotch_map_tests)\n")))))))
> +    (native-inputs (list boost))
> +    (home-page "https://github.com/Tessil/hopscotch-map")
> +    (synopsis "C++ implementation of a hash map and hash set using
> hopscotch hashing")
Should be shortened to fit on a single line.
> +    (description "This package provides a C++ implementation of a
> hash map and
> +a hash set using open-addressing and hopscotch hashing to resolve
> +collisions.")
The description ought to provide a little more information than the
synopsis :)
Same basically holds for packages 3..5, so I won't repeat myself.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 5a6298fc4d..7878aa2a6d 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2588,3 +2588,38 @@  (define-public mpark-variant
      "MPark.Variant provides the C++17 std::variant for C++11/14/17.  It is
 based on the implementation of std::variant in libc++.")
     (license license:boost1.0)))
+
+(define-public tsl-hopscotch-map
+  (package
+    (name "tsl-hopscotch-map")
+    (version "2.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Tessil/hopscotch-map")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "012pw37w000pdxdvps0wsqrw6597cm6i6kr5rpl303qmiwqicb2p"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-cmake-test
+            (lambda _
+              (let ((file (open-file "CMakeLists.txt" "a")))
+                (display "\nenable_testing()\nadd_subdirectory(tests)" file)
+                (close-port file))
+              (substitute* "tests/CMakeLists.txt"
+                (("set\\(Boost_USE_STATIC_LIBS.*") "")
+                (("add_subdirectory\\(\\.\\..*")
+                 "add_test(tsl_hopscotch_map_tests tsl_hopscotch_map_tests)\n")))))))
+    (native-inputs (list boost))
+    (home-page "https://github.com/Tessil/hopscotch-map")
+    (synopsis "C++ implementation of a hash map and hash set using hopscotch hashing")
+    (description "This package provides a C++ implementation of a hash map and
+a hash set using open-addressing and hopscotch hashing to resolve
+collisions.")
+    (license license:expat)))