[bug#75068,rust-team,v2,93/93] gnu: rust-pyo3-0.13: Order alphabetically.

Message ID 6d459d84ca8d7be7a49098556addb6360c3ea1c5.1735070700.git.herman@rimm.ee
State New
Headers
Series Order (gnu packages crates-io) up to |

Commit Message

Herman Rimm Dec. 24, 2024, 8:11 p.m. UTC
  * gnu/packages/crates-io.scm (rust-pyo3-0.13): Order.

Change-Id: I597584b6c06739fad9892e4a2df7fb3b2beb4099
---
 gnu/packages/crates-io.scm | 76 +++++++++++++++++++-------------------
 1 file changed, 38 insertions(+), 38 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2c8352d026..ddd45ca5b6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -63936,6 +63936,44 @@  (define-public rust-pyo3-0.15
        ;; FIXME: fails to initialize Python interpreter.
        #:tests? #f))))
 
+(define-public rust-pyo3-0.13
+  (package
+    (inherit rust-pyo3-0.15)
+    (name "rust-pyo3")
+    (version "0.13.2")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "pyo3" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1hq965lgi25dn578fpn9hjva6zjr1c8rl7lxywijq44aw7lbhds8"))))
+    (arguments
+     `(#:skip-build? #true
+       #:cargo-inputs
+       (("rust-cfg-if" ,rust-cfg-if-1)
+        ("rust-ctor" ,rust-ctor-0.1)
+        ("rust-hashbrown" ,rust-hashbrown-0.9)
+        ("rust-indoc" ,rust-indoc-0.3)
+        ("rust-inventory" ,rust-inventory-0.1)
+        ("rust-libc" ,rust-libc-0.2)
+        ("rust-num-bigint" ,rust-num-bigint-0.3)
+        ("rust-num-complex" ,rust-num-complex-0.3)
+        ("rust-parking-lot" ,rust-parking-lot-0.11)
+        ("rust-paste" ,rust-paste-0.1)
+        ("rust-pyo3-macros" ,rust-pyo3-macros-0.13)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-unindent" ,rust-unindent-0.1))
+       #:cargo-development-inputs
+       (("rust-assert-approx-eq" ,rust-assert-approx-eq-1)
+        ("rust-bitflags" ,rust-bitflags-1.2)
+        ("rust-criterion" ,rust-criterion-0.3)
+        ("rust-half" ,rust-half-1)
+        ("rust-proptest" ,rust-proptest-0.10)
+        ("rust-rustversion" ,rust-rustversion-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-trybuild" ,rust-trybuild-1))))))
+
 (define-public rust-pyo3-build-config-0.23
   (package
     (name "rust-pyo3-build-config")
@@ -64593,44 +64631,6 @@  (define-public rust-pyo3-macros-0.13
         ("rust-quote" ,rust-quote-1)
         ("rust-syn" ,rust-syn-1))))))
 
-(define-public rust-pyo3-0.13
-  (package
-    (inherit rust-pyo3-0.15)
-    (name "rust-pyo3")
-    (version "0.13.2")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "pyo3" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1hq965lgi25dn578fpn9hjva6zjr1c8rl7lxywijq44aw7lbhds8"))))
-    (arguments
-     `(#:skip-build? #true
-       #:cargo-inputs
-       (("rust-cfg-if" ,rust-cfg-if-1)
-        ("rust-ctor" ,rust-ctor-0.1)
-        ("rust-hashbrown" ,rust-hashbrown-0.9)
-        ("rust-indoc" ,rust-indoc-0.3)
-        ("rust-inventory" ,rust-inventory-0.1)
-        ("rust-libc" ,rust-libc-0.2)
-        ("rust-num-bigint" ,rust-num-bigint-0.3)
-        ("rust-num-complex" ,rust-num-complex-0.3)
-        ("rust-parking-lot" ,rust-parking-lot-0.11)
-        ("rust-paste" ,rust-paste-0.1)
-        ("rust-pyo3-macros" ,rust-pyo3-macros-0.13)
-        ("rust-serde" ,rust-serde-1)
-        ("rust-unindent" ,rust-unindent-0.1))
-       #:cargo-development-inputs
-       (("rust-assert-approx-eq" ,rust-assert-approx-eq-1)
-        ("rust-bitflags" ,rust-bitflags-1.2)
-        ("rust-criterion" ,rust-criterion-0.3)
-        ("rust-half" ,rust-half-1)
-        ("rust-proptest" ,rust-proptest-0.10)
-        ("rust-rustversion" ,rust-rustversion-1)
-        ("rust-serde-json" ,rust-serde-json-1)
-        ("rust-trybuild" ,rust-trybuild-1))))))
-
 (define-public rust-pyproject-toml-0.8
   (package
     (name "rust-pyproject-toml")