diff mbox series

[bug#65074,v2,03/13] gnu: Add go-github-com-chyzer-readline

Message ID 6719ec05e59cd4893ce47ab8cc7963bb21030308.1691233116.git.fries1234@protonmail.com
State New
Headers show
Series Add scc | expand

Commit Message

Fries Aug. 5, 2023, 11:01 a.m. UTC
* gnu/packages/golang.scm (go-github-com-chyzer-readline): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 171bd3bdb5..cc8c2357b6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2113,6 +2113,30 @@  (define-public go-github-com-dhowett-go-plist
 types.")
       (license license:giftware))))
 
+(define-public go-github-com-chzyer-readline
+  (package
+    (name "go-github-com-chzyer-readline")
+    (version "1.5.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/chzyer/readline")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1msh9qcm7l1idpmfj4nradyprsr86yhk9ch42yxz7xsrybmrs0pb"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/chzyer/readline"))
+    (propagated-inputs (list go-github-com-chzyer-logex go-golang-org-x-sys
+                             go-github-com-chzyer-test))
+    (home-page "https://github.com/chzyer/readline")
+    (synopsis "Pure Go readline library")
+    (description
+     "Readline is a pure Go implementation of a GNU-Readline like library.")
+    (license license:expat)))
+
 (define-public go-github-com-chzyer-test
   (package
     (name "go-github-com-chzyer-test")