diff mbox series

[bug#65074,v2,06/13] gnu: Add go-github-com-felixge-fgprof

Message ID 1dfe4d84a98bd14a3a5b0a45e1cd9576c85a4294.1691233116.git.fries1234@protonmail.com
State New
Headers show
Series Add scc | expand

Commit Message

Fries Aug. 5, 2023, 11:01 a.m. UTC
* gnu/packages/golang.scm (go-github-com-felixge-fgprof): Add variable.
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index eb5379b540..ab03812125 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2113,6 +2113,33 @@  (define-public go-github-com-dhowett-go-plist
 types.")
       (license license:giftware))))
 
+(define-public go-github-com-felixge-fgprof
+  (package
+    (name "go-github-com-felixge-fgprof")
+    (version "0.9.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/felixge/fgprof")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "03q3vnjd13r944y2qvfncs21lfkgmg0y8z14zz0xda1hz490wha3"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:tests? #f
+           #:import-path "github.com/felixge/fgprof"))
+    (propagated-inputs (list go-github-com-stretchr-testify
+                             go-github-com-google-pprof))
+    (home-page "https://github.com/felixge/fgprof")
+    (synopsis "The Full Go Profiler")
+    (description
+     "Fgprof is a sampling Go profiler that allows you to analyze On-CPU as well as
+@uref{https://www.brendangregg.com/offcpuanalysis.html,Off-CPU} (e.g. I/O) time
+together.")
+    (license license:expat)))
+
 (define-public go-github-com-google-pprof
   (package
     (name "go-github-com-google-pprof")