diff mbox series

[bug#65074,v2,12/13] gnu: Add go-github-com-json-iterator-go

Message ID 1b95f4a754ec6999e2f302a5ede037c8875a393a.1691233116.git.fries1234@protonmail.com
State New
Headers show
Series Add scc | expand

Commit Message

Fries Aug. 5, 2023, 11:02 a.m. UTC
* gnu/packages/golang.scm (go-github-com-json-iterator-go): Add variable.
---
 gnu/packages/golang.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1eb0eae3ec..a5f3542c78 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4377,6 +4377,39 @@  (define-public go-github-com-goccy-go-json
      "Fast JSON encoder/decoder compatible with encoding/json for Go.")
     (license license:expat)))
 
+(define-public go-github-com-json-iterator-go
+  (package
+    (name "go-github-com-json-iterator-go")
+    (version "1.1.12")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/json-iterator/go")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1c8f0hxm18wivx31bs615x3vxs2j3ba0v6vxchsjhldc8kl311bz"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/json-iterator/go"))
+    (propagated-inputs (list go-github-com-stretchr-testify
+                             go-github-com-modern-go-reflect2
+                             go-github-com-modern-go-concurrent
+                             go-github-com-google-gofuzz
+                             go-github-com-davecgh-go-spew))
+    (home-page "https://github.com/json-iterator/go")
+    (synopsis
+     "High-performance, 100% compatible drop-in replacement for encoding/json")
+    (description
+     "This package implements encoding and decoding of JSON as defined in
+@uref{https://rfc-editor.org/rfc/rfc4627.html,RFC 4627} and provides interfaces
+with identical syntax of standard lib encoding/json.  Converting from
+encoding/json to jsoniter is no more than replacing the package with jsoniter
+and variable type declarations (if any).  jsoniter interfaces gives 100%
+compatibility with code using standard lib.")
+    (license license:expat)))
+
 (define-public go-github-com-getsentry-raven-go
   (let ((commit "5c24d5110e0e198d9ae16f1f3465366085001d92")
         (revision "0"))