diff mbox series

[bug#65074,v2,05/13] gnu: Add go-github-com-google-pprof

Message ID 1a37d90138378b438972e53c4d1bf8217a78e6fd.1691233116.git.fries1234@protonmail.com
State New
Headers show
Series Add scc | expand

Commit Message

Fries Aug. 5, 2023, 11:01 a.m. UTC
* gnu/packages/golang.scm (go-github-com-google-pprof): Add variable.
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 81e2a12305..eb5379b540 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2113,6 +2113,33 @@  (define-public go-github-com-dhowett-go-plist
 types.")
       (license license:giftware))))
 
+(define-public go-github-com-google-pprof
+  (package
+    (name "go-github-com-google-pprof")
+    (version "0.0.0-20230728192033-2ba5b33183c6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/google/pprof")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1c5hh0b5cqlhm888lwlf713vv572562x56dpyijs9bzjdy5y54jg"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/google/pprof"))
+    (propagated-inputs (list go-golang-org-x-sys
+                             go-github-com-ianlancetaylor-demangle
+                             go-github-com-chzyer-readline))
+    (home-page "https://github.com/google/pprof")
+    (synopsis
+     "PProf is a tool for visualization and analysis of profiling data")
+    (description
+     "PProf is a tool for collection, manipulation and visualization of performance
+profiles.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-ianlancetaylor-demangle
   (package
     (name "go-github-com-ianlancetaylor-demangle")