diff mbox series

[bug#69980,12/13] gnu: python-nodeenv: Update to 1.8.0.

Message ID 5b312ec5d9cbabf7b1191eebff0da40422120f15.1711287459.git.monego@posteo.net
State New
Headers show
Series Update and cleanup pre-commit & friends. | expand

Commit Message

Vinicius Monego March 24, 2024, 1:40 p.m. UTC
* gnu/packages/python-xyz.scm (python-nodeenv): Update to 1.8.0.
[build-system]: Use pyproject-build-system.
[arguments]: Do not override the check phase, skip tests in #:test-flags
instead.

Change-Id: I01ca1948c30327827d6f76697b471a4d90cd6530
---
 gnu/packages/python-xyz.scm | 16 +++++++---------
 1 file changed, 7 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d7af0646fc..b8abe5fd75 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26813,7 +26813,7 @@  (define-public python-tldr
 (define-public python-nodeenv
   (package
     (name "python-nodeenv")
-    (version "1.4.0")
+    (version "1.8.0")
     (source
      (origin
        ;; There's no tarball in PyPI.
@@ -26823,15 +26823,13 @@  (define-public python-nodeenv
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0y443icx0w7jlzmxmmcm4q8dqfiwgafbb9cp8jpm68mbqxbz40a7"))))
-    (build-system python-build-system)
+        (base32 "0g8zp8zw5nnfc14ml0sil9yh7lnpz3xrdkazdkwg6pf5jqsxlvv9"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda _
-             ;; This test fails. It tries to open a network socket.
-             (invoke "pytest" "-vv" "-k" "not test_smoke"))))))
+     (list #:test-flags
+           #~(list "-k" (string-append
+                         "not test_smoke"
+                         " and not test_smoke_n_system_special_chars"))))
     (native-inputs
      (list python-coverage python-mock python-pytest))
     (home-page "https://ekalinin.github.io/nodeenv/")