diff mbox series

[bug#69980,09/13] gnu: python-cfgv: Update to 3.4.0.

Message ID 0ecea872e409c8625768b6269933a3aeffe6c284.1711287459.git.monego@posteo.net
State New
Headers show
Series Update and cleanup pre-commit & friends. | expand

Commit Message

Vinicius Monego March 24, 2024, 1:40 p.m. UTC
* gnu/packages/python-xyz.scm (python-cfgv): Update to 3.4.0.
[build-system]: Use pyproject-build-system.
[arguments]: Do not override the check phase.

Change-Id: Id666a57e4d619697ffa272893930f1c94d5c283e
---
 gnu/packages/python-xyz.scm | 13 +++----------
 1 file changed, 3 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 23a6490154..cead8ece1d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26902,7 +26902,7 @@  (define-public python-dns-lexicon
 (define-public python-cfgv
   (package
     (name "python-cfgv")
-    (version "3.3.1")
+    (version "3.4.0")
     (source
      (origin
        ;; There are no tests in the PyPI tarball.
@@ -26912,15 +26912,8 @@  (define-public python-cfgv
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1pci97cmn3v45sfch9s3lshidrl0309ls9byidic0l8drkwnkwcj"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "pytest" "-vv")))))))
+        (base32 "0g7jg6dssyax6k85lk8afs8qdzgq138g6ij0jmmhgdv5fzks6k9z"))))
+    (build-system pyproject-build-system)
     (native-inputs
      (list python-pytest))
     (home-page "https://github.com/asottile/cfgv")