diff mbox series

[bug#69980,11/13] gnu: python-identify: Update to 2.5.35.

Message ID 3decec1b473777fe52d7b32c455dea1ea5a5b68c.1711287459.git.monego@posteo.net
State New
Headers show
Series Update and cleanup pre-commit & friends. | expand

Commit Message

Vinicius Monego March 24, 2024, 1:40 p.m. UTC
* gnu/packages/python-xyz.scm (python-identify): Update to 2.5.35.
[build-system]: Use pyproject-build-system.
[arguments]: Use G-Expressions. Do not override the check phase.
[native-inputs]: Add python-ukkonen.

Change-Id: I970507dc358029b4e2cc0a295d19db4b28202544
---
 gnu/packages/python-xyz.scm | 20 ++++++++------------
 1 file changed, 8 insertions(+), 12 deletions(-)

Comments

Nicolas Graves April 17, 2024, 10:07 p.m. UTC | #1
lint complains about permanent redirect from
https://github.com/chriskuehl/identify to
https://github.com/pre-commit/identify


On 2024-03-24 13:40, Vinicius Monego wrote:

> * gnu/packages/python-xyz.scm (python-identify): Update to 2.5.35.
> [build-system]: Use pyproject-build-system.
> [arguments]: Use G-Expressions. Do not override the check phase.
> [native-inputs]: Add python-ukkonen.
>
> Change-Id: I970507dc358029b4e2cc0a295d19db4b28202544
> ---
>  gnu/packages/python-xyz.scm | 20 ++++++++------------
>  1 file changed, 8 insertions(+), 12 deletions(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 03fdccba78..d7af0646fc 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -26717,7 +26717,7 @@ (define-public python-ukkonen
>  (define-public python-identify
>    (package
>      (name "python-identify")
> -    (version "1.4.25")
> +    (version "2.5.35")
>      (source
>       (origin
>         ;; There are no tests in the PyPI tarball.
> @@ -26727,19 +26727,15 @@ (define-public python-identify
>               (commit (string-append "v" version))))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32 "1fqgci6skckcq0x5pnxh6k2qjzn1ndsrgha1j6wwv1ld4g9bd3hz"))))
> -    (build-system python-build-system)
> +        (base32 "0w1wnh4y6xll3980m555k5g4iwwk31pwjx4j0b5x88bdvfml0h4i"))))
> +    (build-system pyproject-build-system)
>      (arguments
> -     `(#:phases
> -       (modify-phases %standard-phases
> -         ;; system-error "utime" "~A" ("No such file or directory")
> -         (delete 'ensure-no-mtimes-pre-1980)
> -         (replace 'check
> -           (lambda* (#:key tests? #:allow-other-keys)
> -             (when tests?
> -               (invoke "pytest" "-vv")))))))
> +     (list
> +      #:phases #~(modify-phases %standard-phases
> +                   ;; system-error "utime" "~A" ("No such file or directory")
> +                   (delete 'ensure-no-mtimes-pre-1980))))
>      (native-inputs
> -     (list python-coverage python-pytest))
> +     (list python-coverage python-pytest python-ukkonen))
>      (propagated-inputs
>       (list python-editdistance))
>      (home-page "https://github.com/chriskuehl/identify")
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 03fdccba78..d7af0646fc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26717,7 +26717,7 @@  (define-public python-ukkonen
 (define-public python-identify
   (package
     (name "python-identify")
-    (version "1.4.25")
+    (version "2.5.35")
     (source
      (origin
        ;; There are no tests in the PyPI tarball.
@@ -26727,19 +26727,15 @@  (define-public python-identify
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1fqgci6skckcq0x5pnxh6k2qjzn1ndsrgha1j6wwv1ld4g9bd3hz"))))
-    (build-system python-build-system)
+        (base32 "0w1wnh4y6xll3980m555k5g4iwwk31pwjx4j0b5x88bdvfml0h4i"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         ;; system-error "utime" "~A" ("No such file or directory")
-         (delete 'ensure-no-mtimes-pre-1980)
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "pytest" "-vv")))))))
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   ;; system-error "utime" "~A" ("No such file or directory")
+                   (delete 'ensure-no-mtimes-pre-1980))))
     (native-inputs
-     (list python-coverage python-pytest))
+     (list python-coverage python-pytest python-ukkonen))
     (propagated-inputs
      (list python-editdistance))
     (home-page "https://github.com/chriskuehl/identify")