diff mbox series

[bug#60695,6/9] gnu: nextpnr-ice40: Enable tests.

Message ID 51964922a525a03b82b8eb0256228a9d1f132c22.1673286570.git.simon@simonsouth.net
State New
Headers show
Series gnu: nextpnr-ice40: Update to 0.5. | expand

Commit Message

Simon South Jan. 9, 2023, 7:26 p.m. UTC
* gnu/packages/fpga.scm (nextpnr-ice40)[source]: Enable recursive checkout.
[arguments]<#:configure-flags>: Add "-DBUILD_TESTS".
<#:tests?>: Remove.
---
 gnu/packages/fpga.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 817ebe3f6b..947fe05dd0 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -284,11 +284,12 @@  (define-public nextpnr-ice40
           (method git-fetch)
           (uri (git-reference
                  (url "https://github.com/YosysHQ/nextpnr")
-                 (commit commit)))
+                 (commit commit)
+                 (recursive? #t)))
           (file-name (git-file-name name version))
           (sha256
            (base32
-            "1fmxsywgs45g88ra7ips5s2niiiwrkyxdcy742ws18dfk2y4vi9c"))))
+            "1llkrh8rk1a1xxzx54apbg49ny2jqzzl2rmbkb8188idipq568ws"))))
       (inputs
        (list boost
              eigen
@@ -299,10 +300,10 @@  (define-public nextpnr-ice40
       (build-system cmake-build-system)
       (arguments
        (list #:configure-flags #~(list "-DARCH=ice40"
+                                       "-DBUILD_TESTS=ON"
                                        (string-append "-DICEBOX_ROOT="
                                                       #$icestorm
-                                                      "/share/icebox"))
-             #:tests? #f))
+                                                      "/share/icebox"))))
       (synopsis "Place-and-Route tool for FPGAs")
       (description "Nextpnr aims to be a vendor neutral, timing driven,
 FOSS FPGA place and route tool.")