diff mbox series

[bug#60695,5/9] gnu: nextpnr-ice40: Use gexps.

Message ID 3a7ade2a7100f62cf7d3e7b4a25bb7829465f404.1673286570.git.simon@simonsouth.net
State New
Headers show
Series gnu: nextpnr-ice40: Update to 0.5. | expand

Commit Message

Simon South Jan. 9, 2023, 7:25 p.m. UTC
* gnu/packages/fpga.scm (nextpnr-ice40)[arguments]: Use gexps.
---
 gnu/packages/fpga.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 0924c34e0c..817ebe3f6b 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -298,11 +298,11 @@  (define-public nextpnr-ice40
              yosys))
       (build-system cmake-build-system)
       (arguments
-       `(#:configure-flags `("-DARCH=ice40"
-                             ,(string-append "-DICEBOX_ROOT="
-                                             (assoc-ref %build-inputs "icestorm")
-                                             "/share/icebox"))
-         #:tests? #f))
+       (list #:configure-flags #~(list "-DARCH=ice40"
+                                       (string-append "-DICEBOX_ROOT="
+                                                      #$icestorm
+                                                      "/share/icebox"))
+             #:tests? #f))
       (synopsis "Place-and-Route tool for FPGAs")
       (description "Nextpnr aims to be a vendor neutral, timing driven,
 FOSS FPGA place and route tool.")