@@ -260,6 +260,42 @@ (define-public python-django-localflavor
that are useful for particular countries or cultures.")
(license license:bsd-3)))
+(define-public python-django-request
+ (package
+ (name "python-django-request")
+ (version "1.5.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/django-request/django-request")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07m4h6whi1zyc75ad22fmz25jhd9k3kf3jf73c4q07bqrclhfd6p"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (if tests?
+ (invoke "python" "runtests.py")
+ (format #t "test suite not run~%")))))))
+ (propagated-inputs
+ (list python-dateutil python-django python-six))
+ (native-inputs
+ (list python-sqlparse python-mock))
+ (home-page "https://django-request.readthedocs.io")
+ (synopsis
+ "Statistics module for django")
+ (description
+ "This package provides a statistics module for django. It stores
+requests in a database for admins to see, it can also be used to get
+statistics on who is online etc.")
+ (license license:expat)))
+
(define-public python-django-simple-math-captcha
(package
(name "python-django-simple-math-captcha")