diff mbox series

[bug#71938,v3,05/25] gnu: Add ghc-crypton-x509-validation.

Message ID 20240722113008.9057-6-romain.garbage@inria.fr
State New
Headers show
Series Add matterhorn package. | expand

Commit Message

Romain GARBAGE July 22, 2024, 11:28 a.m. UTC
* gnu/packages/haskell-crypto.scm (ghc-crypton-x509-validation): New variable.

Change-Id: Ib25c2dee8fef24c763cf70dfa1c615405d250d39
---
 gnu/packages/haskell-crypto.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index 5c69def661..5c5305afa9 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -725,6 +725,33 @@  (define-public ghc-crypton-x509-system
 storage methods")
     (license license:bsd-3)))
 
+(define-public ghc-crypton-x509-validation
+  (package
+    (name "ghc-crypton-x509-validation")
+    (version "1.6.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "crypton-x509-validation" version))
+       (sha256
+        (base32 "1xjhwvmkcy47a6xiqxb3xy944ca7g660203jdrz5xzd46zibfq0f"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "crypton-x509-validation")))
+    (inputs (list ghc-memory
+                  ghc-hourglass
+                  ghc-data-default-class
+                  ghc-pem
+                  ghc-asn1-types
+                  ghc-asn1-encoding
+                  ghc-crypton-x509
+                  ghc-crypton-x509-store
+                  ghc-crypton))
+    (native-inputs (list ghc-tasty ghc-tasty-hunit))
+    (home-page "https://github.com/kazu-yamamoto/crypton-certificate")
+    (synopsis "X.509 Certificate and CRL validation")
+    (description "X.509 Certificate and CRL validation.  please see README")
+    (license license:bsd-3)))
+
 (define-public ghc-cprng-aes
   (package
     (name "ghc-cprng-aes")