[bug#71938,v3,17/25] gnu: Add ghc-unique.
Commit Message
* gnu/packages/haskell-xyz.scm (ghc-unique): New variable.
Change-Id: Id9876b8018f5f8b3bcb82ab0bb13616ed298c31b
---
gnu/packages/haskell-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
@@ -13390,6 +13390,30 @@ (define-public ghc-uniplate
work, but is substantially simpler and faster.")
(license license:bsd-3)))
+(define-public ghc-unique
+ (package
+ (name "ghc-unique")
+ (version "0.4.7.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "Unique" version))
+ (sha256
+ (base32 "14f1qnmhdmbam8qis725dhwq1mk9h86fsnzhkwhsx73ny9z29s1l"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "Unique")))
+ (inputs (list ghc-extra ghc-hashable ghc-unordered-containers))
+ (native-inputs (list ghc-hspec ghc-quickcheck))
+ (arguments
+ `(#:tests? #f ;test Data.List.UniqueUnsorted.removeDuplicates fails
+ #:cabal-revision ("1"
+ "10s0npnfkh7naj49afmyrvnilikp6426fbhi49f97pxrgcmy4dvw")))
+ (home-page "http://hackage.haskell.org/package/Unique")
+ (synopsis "It provides the functionality like unix \"uniq\" utility")
+ (description
+ "Library provides the functions to find unique and duplicate elements in the list")
+ (license license:bsd-3)))
+
(define-public ghc-unix-compat
(package
(name "ghc-unix-compat")