[bug#44518,v3,04/25] gnu: Add ghc-crypton-x509-system.
Commit Message
* gnu/packages/haskell-crypto.scm (ghc-crypton-x509-system): New variable.
Change-Id: Idfadaf630a3bcc4d019738d37ae9ee888f49fd80
---
gnu/packages/haskell-crypto.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
@@ -705,6 +705,26 @@ (define-public ghc-crypton-x509-store
list")
(license license:bsd-3)))
+(define-public ghc-crypton-x509-system
+ (package
+ (name "ghc-crypton-x509-system")
+ (version "1.6.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "crypton-x509-system" version))
+ (sha256
+ (base32 "1jilnr9715njlx1hqvg5lrsrwk12r04maypmh18di0sybwg2cdm4"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "crypton-x509-system")))
+ (inputs (list ghc-pem ghc-crypton-x509 ghc-crypton-x509-store))
+ (home-page "https://github.com/kazu-yamamoto/crypton-certificate")
+ (synopsis "Handle per-operating-system X.509 accessors and storage")
+ (description
+ "System X.509 handling for accessing operating system dependents store and other
+storage methods")
+ (license license:bsd-3)))
+
(define-public ghc-cprng-aes
(package
(name "ghc-cprng-aes")