diff mbox series

[bug#71938,v3,02/25] gnu: Add ghc-crypton-x509.

Message ID 20240722113008.9057-3-romain.garbage@inria.fr
State New
Headers show
Series Add matterhorn package. | expand

Commit Message

Romain GARBAGE July 22, 2024, 11:27 a.m. UTC
* gnu/packages/haskell-crypto.scm (ghc-crypton-x509): New variable.

Change-Id: I0bea5088c2fd23b77f22a2017303bac849c45c29
---
 gnu/packages/haskell-crypto.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index 12ffd10743..9bbf3ee0fc 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -652,6 +652,37 @@  (define-public ghc-crypton
 @end itemize")
     (license license:bsd-3)))
 
+(define-public ghc-crypton-x509
+  (package
+    (name "ghc-crypton-x509")
+    (version "1.7.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "crypton-x509" version))
+       (sha256
+        (base32 "1zyaz0krf08g36g30zr5wn8f2x51l4dj2zcjnhpiw9h05p54mdzb"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "crypton-x509")))
+    (inputs (list ghc-memory
+                  ghc-hourglass
+                  ghc-pem
+                  ghc-asn1-types
+                  ghc-asn1-encoding
+                  ghc-asn1-parse
+                  ghc-crypton))
+    (native-inputs (list ghc-tasty ghc-tasty-quickcheck ghc-x509))
+    (arguments
+     `(#:cabal-revision ("1"
+                         "10a2x47znhbayyfr6fqgq27623akpycyjbfxz4hnavavf1x6ary5")
+       ;; build phase fails when tests are activated.
+       ;; See https://github.com/kazu-yamamoto/crypton-certificate/pull/7
+       #:tests? #f))
+    (home-page "https://github.com/kazu-yamamoto/crypton-certificate")
+    (synopsis "X509 reader and writer")
+    (description "Generic X509 support for Haskell.")
+    (license license:bsd-3)))
+
 (define-public ghc-cprng-aes
   (package
     (name "ghc-cprng-aes")