diff mbox series

[bug#71938,v3,22/25] gnu: Add ghc-hclip.

Message ID 20240722113008.9057-23-romain.garbage@inria.fr
State New
Headers show
Series Add matterhorn package. | expand

Commit Message

Romain GARBAGE July 22, 2024, 11:28 a.m. UTC
gnu/packages/haskell-xyz.scm (ghc-hclip): New variable.

Change-Id: I2d1a2d6e1983eb89a5e61eb05204c2e1c0dc3634
---
 gnu/packages/haskell-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 9bacacf9fc..10618be91a 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15153,6 +15153,30 @@  (define-public ghc-commonmark-pandoc
 Pandoc types.")
     (license license:bsd-3)))
 
+(define-public ghc-hclip
+  (package
+    (name "ghc-hclip")
+    (version "3.0.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "Hclip" version))
+       (sha256
+        (base32 "04ppwm7vfzndrys8x1n8vfb41vzwx59r9xp4dkbiqmrms390pj6q"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "Hclip")))
+    (inputs (list ghc-strict))
+    (home-page "https://github.com/jetho/Hclip")
+    (synopsis
+     "Small cross-platform library for reading and modifying the system clipboard")
+    (description
+     "This package provides a small cross-platform library for reading and modifying
+the system clipboard. .  Hclip works on Windows, Mac OS X and Linux (but see the
+requirements below!). .  Requirements: . * Windows: No additional requirements.
+. * Mac OS X: Requires the pbcopy and pbpaste commands, which ship with Mac OS
+X. . * Linux: Requires xclip or xsel installed.")
+    (license license:bsd-3)))
+
 (define-public ghc-hslua-module-path
   (package
     (name "ghc-hslua-module-path")