diff mbox series

[bug#44518,v3,21/25] gnu: Add ghc-vty-6.

Message ID 20240722113008.9057-22-romain.garbage@inria.fr
State New
Headers show
Series Add matterhorn package. | expand

Commit Message

Romain GARBAGE July 22, 2024, 11:28 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-vty-6): New variable.

Change-Id: I2e2dbbe0e99d26f38494fb6bdb51bc6d67e5c02c
---
 gnu/packages/haskell-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 787f70b510..9bacacf9fc 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -14179,6 +14179,33 @@  (define-public ghc-vty-unix
     (description "This package provides Unix terminal support for Vty.")
     (license license:bsd-3)))
 
+(define-public ghc-vty-6
+  (package
+    (name "ghc-vty")
+    (version "6.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "vty" version))
+       (sha256
+        (base32 "0ywqfdngfv5pnsk5pa99yizpbhdq856sy3z70q2hmpmlc2r4h7vg"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "vty")))
+    (inputs (list ghc-blaze-builder ghc-microlens ghc-microlens-mtl
+                  ghc-utf8-string ghc-vector))
+    (home-page "https://github.com/jtdaugherty/vty")
+    (synopsis "A simple terminal UI library")
+    (description
+     "vty is terminal GUI library in the niche of ncurses.  It is intended to be easy
+to use and to provide good support for common terminal types. .  See the
+@@vty-examples@@ package as well as the program
+@@examples/interactive_terminal_test.hs@@ included in the @@vty@@ repository for
+examples on how to use the library. .  Import the @@Graphics.Vty@@ convenience
+module to get access to the core parts of the library. . © 2006-2007 Stefan
+O'Rear; BSD3 license. . © Corey O'Connor; BSD3 license. . © Jonathan
+Daugherty; BSD3 license.")
+    (license license:bsd-3)))
+
 (define-public ghc-wave
   (package
     (name "ghc-wave")