diff mbox series

[bug#71938,v3,20/25] gnu: Add ghc-vty-unix.

Message ID 20240722113008.9057-21-romain.garbage@inria.fr
State New
Headers show
Series Add matterhorn package. | expand

Commit Message

Romain GARBAGE July 22, 2024, 11:28 a.m. UTC
gnu/packages/haskell-xyz.scm (ghc-vty-unix): New variable.

Change-Id: Idf8e550a5d7b645d19af177dd65c5956ba3ab478
---
 gnu/packages/haskell-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index baf797a8ca..787f70b510 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -14154,6 +14154,31 @@  (define-public ghc-vty-crossplatform
 package so you don't have to conditionally depend on them in your cabal file.")
     (license license:bsd-3)))
 
+(define-public ghc-vty-unix
+  (package
+    (name "ghc-vty-unix")
+    (version "0.2.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "vty-unix" version))
+       (sha256
+        (base32 "1hfxc7qw884vlq8qshhyndl3zs10jc2xr6i69vhasjywkvh6gay2"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "vty-unix")))
+    (inputs (list ghc-blaze-builder
+                  ghc-vty-6
+                  ghc-vector
+                  ghc-utf8-string
+                  ghc-microlens
+                  ghc-microlens-mtl
+                  ghc-microlens-th
+                  ghc-ansi-terminal))
+    (home-page "http://hackage.haskell.org/package/vty-unix")
+    (synopsis "Unix backend for Vty")
+    (description "This package provides Unix terminal support for Vty.")
+    (license license:bsd-3)))
+
 (define-public ghc-wave
   (package
     (name "ghc-wave")