diff mbox series

[bug#44518,v3,19/25] gnu: Add ghc-vty-crossplatform.

Message ID 20240722113008.9057-20-romain.garbage@inria.fr
State New
Headers show
Series Add matterhorn package. | expand

Commit Message

Romain GARBAGE July 22, 2024, 11:28 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-vty-crossplatform): New variable.

Change-Id: Icbd33d9bbd7561bdb6178b3431edef6a1db92fcb
---
 gnu/packages/haskell-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7558a677a4..baf797a8ca 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -14134,6 +14134,26 @@  (define-public ghc-vty
 to use and to provide good support for common terminal types.")
     (license license:bsd-3)))
 
+(define-public ghc-vty-crossplatform
+  (package
+    (name "ghc-vty-crossplatform")
+    (version "0.4.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "vty-crossplatform" version))
+       (sha256
+        (base32 "06iwxgqrqzz05hmic7z5hxd48x0i49sk935vm0xfi0xq28sl7r9m"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "vty-crossplatform")))
+    (inputs (list ghc-vty-6 ghc-vty-unix ghc-random ghc-string-qq))
+    (home-page "http://hackage.haskell.org/package/vty-crossplatform")
+    (synopsis "Cross-platform support for Vty")
+    (description
+     "This package provides a generic interface for multiple Vty platforms in one
+package so you don't have to conditionally depend on them in your cabal file.")
+    (license license:bsd-3)))
+
 (define-public ghc-wave
   (package
     (name "ghc-wave")