diff mbox series

[bug#44518,v3,18/25] gnu: Add ghc-unix-compat-7.

Message ID 20240722113008.9057-19-romain.garbage@inria.fr
State New
Headers show
Series Add matterhorn package. | expand

Commit Message

Romain GARBAGE July 22, 2024, 11:28 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-unix-compat-7): New variable.

Change-Id: I28e8e4924d4f829dd07059aa205d894803409320
---
 gnu/packages/haskell-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index d8d0ddfb98..7558a677a4 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13437,6 +13437,28 @@  (define-public ghc-unix-compat
 isn't available, portable implementations are used.")
     (license license:bsd-3)))
 
+(define-public ghc-unix-compat-7
+  (package
+    (name "ghc-unix-compat")
+    (version "0.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "unix-compat" version))
+       (sha256
+        (base32 "0gz30f4g3gyjz60jbcg072ms67pwdn4by6wvdkg63hjshgl0cj60"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "unix-compat")))
+    (native-inputs (list ghc-monad-parallel ghc-hspec ghc-hunit ghc-extra
+                         ghc-temporary))
+    (home-page "https://github.com/haskell-pkg-janitors/unix-compat")
+    (synopsis "Portable POSIX-compatibility layer")
+    (description
+     "This package provides portable implementations of parts of the unix package.
+This package re-exports the unix package when available.  When it isn't
+available, portable implementations are used.")
+    (license license:bsd-3)))
+
 (define-public ghc-unix-time
   (package
     (name "ghc-unix-time")