diff mbox series

[bug#44518,v3,12/25] gnu: Add ghc-bimap.

Message ID 20240722113008.9057-13-romain.garbage@inria.fr
State New
Headers show
Series Add matterhorn package. | expand

Commit Message

Romain GARBAGE July 22, 2024, 11:28 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-bimap): New variable.

Change-Id: Ib6ffebff5417273afaa3a08005aae3445606d6d2
---
 gnu/packages/haskell-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 3bdc8d6d6b..60d25dd4bf 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -972,6 +972,27 @@  (define-public ghc-bifunctors
     (description "This package provides bifunctors for Haskell.")
     (license license:bsd-3)))
 
+(define-public ghc-bimap
+  (package
+    (name "ghc-bimap")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "bimap" version))
+       (sha256
+        (base32 "158cdwk9jwklcfgbn62dqq255i40w13ifggsdps87sxc5q7lpd5h"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "bimap")))
+    (native-inputs (list ghc-quickcheck))
+    (home-page "https://github.com/joelwilliamson/bimap")
+    (synopsis "Bidirectional mapping between two key types")
+    (description
+     "This package provides a data structure representing a bidirectional mapping
+between two key types.  Each value in the bimap is associated with exactly one
+value of the opposite type.")
+    (license license:bsd-3)))
+
 (define-public ghc-bindings-dsl
   (package
     (name "ghc-bindings-dsl")