diff mbox series

[bug#71938,v3,10/25] gnu: Add ghc-modern-uri.

Message ID 20240722113008.9057-11-romain.garbage@inria.fr
State New
Headers show
Series Add matterhorn package. | expand

Commit Message

Romain GARBAGE July 22, 2024, 11:28 a.m. UTC
* gnu/packages/haskell-web.scm (ghc-modern-uri): New variable.

Change-Id: I62d4c2722303cbeb9a7ef1acd3f12f355cf67509
---
 gnu/packages/haskell-web.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 16a38fd760..bd33abdcb0 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -924,6 +924,35 @@  (define-public ghc-mime-types
      "This library provides basic MIME type handling types and functions.")
     (license license:expat)))
 
+(define-public ghc-modern-uri
+  (package
+    (name "ghc-modern-uri")
+    (version "0.3.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "modern-uri" version))
+       (sha256
+        (base32 "1sag8l91qd7xs56rlx8r6dz9zxxmqsnfw0v47az7l8nirv7zjih2"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "modern-uri")))
+    (inputs (list ghc-quickcheck
+                  ghc-hashable
+                  ghc-megaparsec
+                  ghc-profunctors
+                  ghc-reflection
+                  ghc-tagged))
+    (native-inputs (list ghc-hspec
+                         ghc-hspec-megaparsec
+                         ghc-hspec-discover))
+    (arguments
+     `(#:cabal-revision ("1"
+                         "0c0mr8aqs963nmy7i8yfih24snaijgwkxim2q2khw12capshac0q")))
+    (home-page "https://github.com/mrkkrp/modern-uri")
+    (synopsis "Modern library for working with URIs")
+    (description "Modern library for working with URIs.")
+    (license license:bsd-3)))
+
 (define-public ghc-html
   (package
     (name "ghc-html")