diff mbox series

[bug#44518,v3,09/25] gnu: Add ghc-mattermost-api-qc.

Message ID 20240722113008.9057-10-romain.garbage@inria.fr
State New
Headers show
Series Add matterhorn package. | expand

Commit Message

Romain GARBAGE July 22, 2024, 11:28 a.m. UTC
* gnu/packages/haskell-web.scm (ghc-mattermost-api-qc): New variable.

Change-Id: If28b8a03170bb235b2418329d408fec8f06d4b7c
---
 gnu/packages/haskell-web.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 8021cbaefc..16a38fd760 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -885,6 +885,27 @@  (define-public ghc-mattermost-api
 server.")
     (license license:bsd-3)))
 
+(define-public ghc-mattermost-api-qc
+  (package
+    (name "ghc-mattermost-api-qc")
+    (version "90000.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "mattermost-api-qc" version))
+       (sha256
+        (base32 "0lrb8l8nbrdp4y2ala8hchr8ikv5hqw710ffiiw1sz6z2dqiqbxm"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "mattermost-api-qc")))
+    (inputs (list ghc-mattermost-api ghc-quickcheck))
+    (home-page "https://github.com/matterhorn-chat/mattermost-api-qc")
+    (synopsis "QuickCheck instances for the Mattermost client API library")
+    (description
+     "This package provides a library providing @code{QuickCheck} for the
+mattermost-api library to allow testing.  This is provided as a separate library
+to allow use of the API library without testing dependencies.")
+    (license license:isc)))
+
 (define-public ghc-mime-types
   (package
     (name "ghc-mime-types")