diff mbox series

[bug#70317,08/13] gnu: packages: Add go-git-sr-ht-sircmpwn-go-bare

Message ID 20240410081012.25854-8-jesse@eisses.email
State New
Headers show
Series [bug#70317,01/13] gnu: packages: Add go-github-com-golang-jwt-jwt-v3 | expand

Commit Message

Jesse Eisses April 10, 2024, 8:10 a.m. UTC
Change-Id: I5de06d7bc4a109a1d2a7007cf43584200304a065
---
 gnu/packages/golang-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 2ee165e012..5a2b0df32f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2984,6 +2984,31 @@  (define-public go-git-sr-ht-emersion-go-sqlite3-fts5
 @@url{https://github.com/mattn/go-sqlite3,go-sqlite3}.")
     (license license:expat)))
 
+(define-public go-git-sr-ht-sircmpwn-go-bare
+  (package
+    (name "go-git-sr-ht-sircmpwn-go-bare")
+    (version "0.0.0-20210406120253-ab86bc2846d9")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~sircmpwn/go-bare")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zh36qppk8lscd8mysy0anm2vw5c74c10f4qvhd541wxm06di928"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "git.sr.ht/~sircmpwn/go-bare"))
+    (propagated-inputs
+     `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
+       ("go-git-sr-ht-sircmpwn-getopt" ,go-git-sr-ht-sircmpwn-getopt)))
+    (home-page "https://git.sr.ht/~sircmpwn/go-bare")
+    (synopsis "Implementation of the BARE message format")
+    (description "An implementation of the BARE message format for Go.")
+    (license license:asl2.0)))
+
 (define-public go-go-uber-org-automaxprocs
   (package
     (name "go-go-uber-org-automaxprocs")