diff mbox series

[bug#70317,04/13] gnu: packages: Add go-github-com-pires-go-proxyproto

Message ID 20240410081012.25854-4-jesse@eisses.email
State New
Headers show
Series [bug#70317,01/13] gnu: packages: Add go-github-com-golang-jwt-jwt-v3 | expand

Commit Message

Jesse Eisses April 10, 2024, 8:09 a.m. UTC
Change-Id: Iec8e8ead7e18cbbd9be00ec398d11e632e4b2ac4
---
 gnu/packages/golang-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 2213c040b5..70909de050 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2407,6 +2407,31 @@  (define-public go-github-com-pierrec-cmdflag
 on top of the standard library @code{flag} package.")
     (license license:bsd-3)))
 
+(define-public go-github-com-pires-go-proxyproto
+  (package
+    (name "go-github-com-pires-go-proxyproto")
+    (version "0.7.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pires/go-proxyproto")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1p18w555xp187fl807h1yd092cvs8jarp98pa76zl84rxlk4k2h4"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:go go-1.18
+      #:import-path "github.com/pires/go-proxyproto"))
+    (home-page "https://github.com/pires/go-proxyproto")
+    (synopsis "Implementation of the PROXY protocol")
+    (description
+     "Package proxyproto implements Proxy Protocol (v1 and v2) parser and writer, as
+per specification: @@url{https://www.haproxy.org/download/2.3/doc/proxy-protocol.txt}")
+    (license license:asl2.0)))
+
 (define-public go-github-com-prometheus-client-model
   (let ((commit "14fe0d1b01d4d5fc031dd4bec1823bd3ebbe8016")
         (revision "2"))