diff mbox series

[bug#70317,01/13] gnu: packages: Add go-github-com-golang-jwt-jwt-v3

Message ID 20240410081012.25854-1-jesse@eisses.email
State New
Headers show
Series [bug#70317,01/13] gnu: packages: Add go-github-com-golang-jwt-jwt-v3 | expand

Commit Message

Jesse Eisses April 10, 2024, 8:09 a.m. UTC
Change-Id: I2382208434859b7a9b9a314930fa8769072964c7
---
 gnu/packages/golang-crypto.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 8d0e0ddb64..292734a8d6 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -20,6 +20,7 @@ 
 ;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
 ;;; Copyright © 2023 Jack Hill <jackhill@jackhill.us>
 ;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -478,6 +479,24 @@  (define-public go-github-com-golang-jwt-jwt-v4
 RSA, RSA-PSS, and ECDSA, though hooks are present for adding your own.")
     (license license:expat)))
 
+(define-public go-github-com-golang-jwt-jwt-v3
+  (package
+    (inherit go-github-com-golang-jwt-jwt-v4)
+    (name "go-github-com-golang-jwt-jwt-v3")
+    (version "3.2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/golang-jwt/jwt")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0hq8wz11g6kddx9ab0icl5h3k4lrivk1ixappnr5db2ng2wjks9c"))))
+    (arguments
+     (list
+      #:import-path "github.com/golang-jwt/jwt"))))
+
 (define-public go-github-com-golang-jwt-jwt-v5
   (package
     (inherit go-github-com-golang-jwt-jwt-v4)