diff mbox series

[bug#70317,10/13] gnu: packages: Add go-github-com-prometheus-client-golang-v1.17

Message ID 20240410081012.25854-10-jesse@eisses.email
State New
Headers show
Series [bug#70317,01/13] gnu: packages: Add go-github-com-golang-jwt-jwt-v3 | expand

Commit Message

Jesse Eisses April 10, 2024, 8:10 a.m. UTC
Change-Id: I5e1ee54b68389658e1a87ed8fedbd0accde20230
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 20ce4b5518..f3e69ebde1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8057,6 +8057,28 @@  (define-public go-github-com-prometheus-client-golang
     (home-page "https://github.com/prometheus/client_golang")
     (license license:asl2.0)))
 
+(define-public go-github-com-prometheus-client-golang-v1.17
+  (package
+    (inherit go-github-com-prometheus-client-golang)
+    (name "go-github-com-prometheus-client-golang")
+    (version "1.17.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/prometheus/client_golang")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1v8vdvi9wlpf18nxi62diysfnh9gc3c3cqq6hvx378snsvvl6n82"))))
+
+    (propagated-inputs (list go-github-com-beorn7-perks-quantile
+                             go-github-com-golang-protobuf-proto
+                             go-github-com-prometheus-client-model-v0.5
+                             go-github-com-prometheus-common-v0.45
+                             go-github-com-prometheus-procfs
+                             go-github-com-cespare-xxhash))))
+
 (define-public go-github-com-zalando-go-keyring
   (package
     (name "go-github-com-zalando-go-keyring")