diff mbox series

[bug#64249,v9,24/34] gnu: Add ocaml-ppx-deriving-yaml.

Message ID 20240110074336.24651-24-julien@lepiller.eu
State New
Headers show
Series [bug#64249,v9,01/34] gnu: ocaml: Update to 4.14.1. | expand

Commit Message

Julien Lepiller Jan. 10, 2024, 7:43 a.m. UTC
From: Arnaud DABY-SEESARAM <ds-ac@nanein.fr>

* gnu/packages/ocaml.scm (ocaml-ppx-deriving-yaml): New variable.

Change-Id: I2677ce5b630b77abdec7743cd25c4193ca7b351e
---
 gnu/packages/ocaml.scm | 29 +++++++++++++++++++++++++++--
 1 file changed, 27 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3e7f99407a..2a513bf149 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2621,10 +2621,10 @@  (define-public ocaml-yaml
        (method git-fetch)
        (uri (git-reference
               (url home-page)
-              (commit version)))
+              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "054ca6071bfkdbm5vlmnk6ic43561xl9igv87zgkbq4qry16a7s7"))))
+        (base32 "1m0i9qdazmziswfw1bz4m1x9mlzqyv336vbrss0c21am4im9n6k6"))))
     (build-system dune-build-system)
     (propagated-inputs (list ocaml-ppx-sexp-conv ocaml-ctypes ocaml-bos))
     (native-inputs (list ocaml-fmt
@@ -2644,6 +2644,31 @@  (define-public ocaml-yaml
 layer.")
     (license license:isc)))
 
+(define-public ocaml-ppx-deriving-yaml
+  (package
+    (name "ocaml-ppx-deriving-yaml")
+    (version "0.2.1")
+    (home-page "https://github.com/patricoferris/ppx_deriving_yaml")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url home-page)
+              (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1cxcqgvyl4ykyl86mf2d4ka6frnq51m1yqy0z5v6vdxkixllf9jd"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-ppxlib ocaml-ppx-deriving ocaml-yaml
+                             ocaml-odoc))
+    (native-inputs (list ocaml-alcotest ocaml-bos ocaml-mdx ocaml-ezjsonm))
+    (properties `((upstream-name . "ppx_deriving_yaml")))
+    (synopsis "Yaml PPX Deriver")
+    (description
+     "This package contains @code{deriving} conversion functions to and from
+yaml for OCaml types.")
+    (license license:isc)))
+
 (define-public ocaml-parmap
   (package
     (name "ocaml-parmap")