diff mbox series

[bug#64249,v9,20/34] gnu: Add ocaml-ppx-deriving-yojson.

Message ID 20240110074336.24651-20-julien@lepiller.eu
State New
Headers show
Series [bug#64249,v9,01/34] gnu: ocaml: Update to 4.14.1. | expand

Commit Message

Julien Lepiller Jan. 10, 2024, 7:43 a.m. UTC
From: Arnaud DABY-SEESARAM <ds-ac@nanein.fr>

* gnu/packages/ocaml.scm (ocaml-ppx-deriving-yojson): New variable.

Change-Id: I3f5dfdf39c7e7d9655fc26ee6cc88a2c30485d57
---
 gnu/packages/ocaml.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index cba67159ac..49d6ea9f4d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -29,6 +29,7 @@ 
 ;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
 ;;; Copyright © 2023 Csepp <raingloom@riseup.net>
 ;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;; Copyright © 2023 Arnaud DABY-SEESARAM <ds-ac@nanein.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6210,6 +6211,31 @@  (define-public ocaml-ppx-derivers
 as part of the same ocaml-migrate-parsetree driver.")
     (license license:bsd-3)))
 
+(define-public ocaml-ppx-deriving-yojson
+  (package
+    (name "ocaml-ppx-deriving-yojson")
+    (version "3.7.0")
+    (home-page "https://github.com/ocaml-ppx/ppx_deriving_yojson")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append home-page "/archive/refs/tags/v" version ".tar.gz"))
+       (sha256
+        (base32 "1h7vz7lhvsgn6nl68g3dhhghlm884xpa1xawm6wm54pjc57gc6xx"))))
+    (build-system dune-build-system)
+    (propagated-inputs
+      (list ocaml-yojson
+            ocaml-result
+            ocaml-ppx-deriving
+            ocaml-ppxlib))
+    (native-inputs (list ocaml-ounit))
+    (properties `((upstream-name . "ppx_deriving_yojson")))
+    (synopsis "JSON codec generator for OCaml")
+    (description
+     "ppx_deriving_yojson is a ppx_deriving plugin that provides a JSON codec
+generator.")
+    (license license:expat)))
+
 (define-public ocaml-cinaps
   ;; The commit removes the unused dependency of ocaml-ppx-jane. We need to
   ;; use this as we would otherwise have a dependency loop between