diff mbox series

[bug#64249,v9,23/34] gnu: Add ocaml-yaml.

Message ID 20240110074336.24651-23-julien@lepiller.eu
State New
Headers show
Series [bug#64249,v9,01/34] gnu: ocaml: Update to 4.14.1. | expand

Commit Message

Julien Lepiller Jan. 10, 2024, 7:43 a.m. UTC
From: Arnaud DABY-SEESARAM <ds-ac@nanein.fr>

* gnu/packages/ocaml.scm (ocaml-yaml): New variable.

Change-Id: Ia890e505dd3ff0fe9a8c243adef460e0475d9e81
---
 gnu/packages/ocaml.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8cfa1ab300..3e7f99407a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2611,6 +2611,39 @@  (define-public ocaml-ppx-tools
 syntactic tools.")
     (license license:expat)))
 
+(define-public ocaml-yaml
+  (package
+    (name "ocaml-yaml")
+    (version "3.2.0")
+    (home-page "https://github.com/avsm/ocaml-yaml")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url home-page)
+              (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "054ca6071bfkdbm5vlmnk6ic43561xl9igv87zgkbq4qry16a7s7"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-ppx-sexp-conv ocaml-ctypes ocaml-bos))
+    (native-inputs (list ocaml-fmt
+                         ocaml-sexplib
+                         ocaml-logs
+                         ocaml-mdx
+                         ocaml-alcotest
+                         ocaml-crowbar
+                         ocaml-junit-alcotest
+                         ocaml-ezjsonm))
+    (synopsis "Parse and generate YAML 1.1/1.2 files")
+    (description
+     "This package is an OCaml library to parse and generate the YAML file
+format.  It is intended to be interoperable with the @code{Ezjsonm}
+JSON handling library, if the simple common subset of Yaml is used.  Anchors and
+other advanced Yaml features are not implemented in the JSON compatibility
+layer.")
+    (license license:isc)))
+
 (define-public ocaml-parmap
   (package
     (name "ocaml-parmap")