diff mbox series

[bug#64249,v9,16/34] gnu: ocaml-bin-prot: Update to 0.16.0.

Message ID 20240110074336.24651-16-julien@lepiller.eu
State New
Headers show
Series [bug#64249,v9,01/34] gnu: ocaml: Update to 4.14.1. | expand

Commit Message

Julien Lepiller Jan. 10, 2024, 7:43 a.m. UTC
* gnu/packages/ocaml.scm (ocam-bin-prot): Update to 0.16.0.
(bap)[arguments]: Fix code after ocaml-bin-prot changes.
---
 gnu/packages/ocaml.scm | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 062bef401a..dcb66d7f59 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5036,6 +5036,11 @@  (define-public bap
                 ;; We don't have a monolithic llvm
                 (substitute* "oasis/llvm.setup.ml.in"
                   (("llvm_static = \"true\"") "true"))
+                ;; Package update removed Make_binable, which was an alias
+                ;; for Make_binable_without_uuid
+                (substitute* (find-files "." ".")
+                  (("Utils.Make_binable1\\(") "Utils.Make_binable1_without_uuid(")
+                  (("Utils.Make_binable\\(") "Utils.Make_binable_without_uuid("))
                 (invoke "./configure" "--prefix"
                         (assoc-ref outputs "out")
                         "--libdir"
@@ -6494,7 +6499,7 @@  (define-public ocaml-ppx-stable-witness
 (define-public ocaml-bin-prot
   (package
     (name "ocaml-bin-prot")
-    (version "0.15.0")
+    (version "0.16.0")
     (source
       (origin
         (method git-fetch)
@@ -6503,7 +6508,7 @@  (define-public ocaml-bin-prot
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-          (base32 "1qfqglscc25wwnjx7byqmjcnjww1msnr8940gyg8h93wdq43fjnh"))))
+          (base32 "1ybs0152ilgr8sa1hqnc2jj0gbvg855ixl3c5b2pjbnk7blhqnd8"))))
     (build-system dune-build-system)
     (propagated-inputs
       (list ocaml-base
@@ -6512,6 +6517,7 @@  (define-public ocaml-bin-prot
             ocaml-ppx-fields-conv
             ocaml-ppx-optcomp
             ocaml-ppx-sexp-conv
+            ocaml-ppx-stable-witness
             ocaml-ppx-variants-conv))
     (properties `((upstream-name . "bin_prot")))
     (home-page "https://github.com/janestreet/bin_prot")