diff mbox series

[bug#67813,09/12] gnu: Add python-contourpy.

Message ID 20231213215635.15562-9-ngraves@ngraves.fr
State New
Headers show
Series [bug#67813,01/12] gnu: meson/newer: Update to 1.2.1. | expand

Commit Message

Nicolas Graves Dec. 13, 2023, 9:56 p.m. UTC
* gnu/packages/python-xyz.scm (python-contourpy): New variable.
---
 gnu/packages/python-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2cc687547a..fd9e404f0b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16296,6 +16296,39 @@  (define-public python-texttable
 tables.")
     (license license:expat)))
 
+(define-public python-contourpy
+  (package
+    (name "python-contourpy")
+    (version "1.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "contourpy" version))
+       (sha256
+        (base32 "1az80zv067rcybm5x93j7rfiakbwiv1h8l58gnki4wjbwb13gfln"))))
+    (build-system pyproject-build-system)
+    (arguments
+     ;; Image tests require matplotlib and create a circular dependency.
+     (list #:test-flags
+           #~(list "-m" "not image")))
+    (propagated-inputs
+     (list python-numpy))
+    (native-inputs
+     (list cmake
+           meson-python
+           pkg-config
+           pybind11
+           python-pytest
+           python-pytest-cov
+           python-wurlitzer))
+    (home-page "https://github.com/contourpy/contourpy")
+    (synopsis
+     "Python library for calculating contours of 2D quadrilateral grids")
+    (description
+     "This package provide a python library for calculating contours of 2D
+quadrilateral grids.")
+    (license license:bsd-3)))
+
 (define-public python-atomicwrites
   (package
     (name "python-atomicwrites")