diff mbox series

[bug#67813,05/12] gnu: Add python-tzdata.

Message ID 20231213215635.15562-5-ngraves@ngraves.fr
State New
Headers show
Series [bug#67813,01/12] gnu: meson/newer: Update to 1.2.1. | expand

Commit Message

Nicolas Graves Dec. 13, 2023, 9:56 p.m. UTC
* gnu/packages/time.scm (python-tzdata): New variable.
---
 gnu/packages/time.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 5c8f65a1e6..64772258ad 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -337,6 +337,23 @@  (define-public python-timezonefinder
 timezone for given coordinates on earth entirely offline.")
     (license expat)))
 
+(define-public python-tzdata
+  (package
+    (name "python-tzdata")
+    (version "2023.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "tzdata" version))
+       (sha256
+        (base32 "0fksj1gcr54yqvwiplnb9bg775k5v82vxcdxjm7hvjsawl41xvqi"))))
+    (build-system pyproject-build-system)
+    (arguments '(#:tests? #f))  ; No tests.
+    (home-page "https://github.com/python/tzdata")
+    (synopsis "Provider of IANA time zone data")
+    (description "This package provides IANA time zone data.")
+    (license asl2.0)))
+
 (define-public python-tzlocal
   (package
     (name "python-tzlocal")