diff mbox series

[bug#67813,07/12] gnu: python-pytest-xdist: Use pyproject-build-system.

Message ID 20231213215635.15562-7-ngraves@ngraves.fr
State New
Headers show
Series [bug#67813,01/12] gnu: meson/newer: Update to 1.2.1. | expand

Commit Message

Nicolas Graves Dec. 13, 2023, 9:56 p.m. UTC
* gnu/packages/check.scm (python-pytest-xdist): Use pyproject-build-system.
---
 gnu/packages/check.scm | 10 +---------
 1 file changed, 1 insertion(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 5181d3a164..8d1f0f8c2c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1664,15 +1664,7 @@  (define-public python-pytest-xdist
        (sha256
         (base32
          "1psf5dqxvc38qzxvc305mkg5xpdmdkbkkfiyqlmdnkgh7z5dx025"))))
-    (build-system python-build-system)
-    (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "pytest" "-vv"
-                       "-n" (number->string (parallel-job-count)))))))))
+    (build-system pyproject-build-system)
     (native-inputs (list python-setuptools-scm python-filelock python-pytest))
     (propagated-inputs (list python-execnet python-pytest-forked))
     (home-page "https://github.com/pytest-dev/pytest-xdist")