diff mbox series

[bug#67813,06/12] gnu: python-jinja2: Update to 3.1.2.

Message ID 20231213215635.15562-6-ngraves@ngraves.fr
State New
Headers show
Series [bug#67813,01/12] gnu: meson/newer: Update to 1.2.1. | expand

Commit Message

Nicolas Graves Dec. 13, 2023, 9:56 p.m. UTC
* gnu/packages/python-xyz.scm (python-jinja2): Update to 3.1.2. Format.
[build-system]: Use pyproject-build-system.
[arguments]: Remove uneeded argument.
---
 gnu/packages/python-xyz.scm | 16 +++-------------
 1 file changed, 3 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0f4b8454ad..a13ed2ab52 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5531,26 +5531,17 @@  (define-public python-markupsafe
 for Python.")
     (license license:bsd-3)))
 
-
 (define-public python-jinja2
   (package
     (name "python-jinja2")
-    (version "3.1.1")
+    (version "3.1.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Jinja2" version))
        (sha256
-        (base32
-         "1saawzys14l1p4kafs7hkihmnvqjq8fwxjmkjiqx3jq1nm5ys2v4"))))
-    (build-system python-build-system)
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda* (#:key tests? #:allow-other-keys)
-                      (if tests?
-                          (invoke "pytest" "-vv")
-                          (format #t "test suite not run~%")))))))
+        (base32 "0lp86yadzf8dph67f6g3yxmvnhrzzi863z58jmsrx2j059q1ld9i"))))
+    (build-system pyproject-build-system)
     (native-inputs (list python-pytest))
     (propagated-inputs (list python-markupsafe))
     (home-page "https://jinja.palletsprojects.com/")
@@ -5560,7 +5551,6 @@  (define-public python-jinja2
 written in pure Python.")
     (license license:bsd-3)))
 
-
 (define-public python-jinja2-time
   (package
     (name "python-jinja2-time")