diff mbox series

[bug#66263,06/23] gnu: microscheme: Move to avr-xyz.

Message ID 20230929091627.7820-6-jean@foundationdevices.com
State New
Headers show
Series guix: Add avr as a platform. | expand

Commit Message

Jean-Pierre De Jesus DIAZ Sept. 29, 2023, 9:16 a.m. UTC
* gnu/packages/avr.scm (microscheme): Remove from file.

* gnu/packages/avr-xyz.scm (microscheme): New variable.
---
 gnu/packages/avr-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++++
 gnu/packages/avr.scm     | 42 +---------------------------------------
 2 files changed, 42 insertions(+), 41 deletions(-)

Comments

Efraim Flashner Oct. 4, 2023, 2:07 p.m. UTC | #1
This missing the copyright headers associated with microscheme which
should be copied over also

On Fri, Sep 29, 2023 at 11:16:10AM +0200, Jean-Pierre De Jesus DIAZ wrote:
> * gnu/packages/avr.scm (microscheme): Remove from file.
> 
> * gnu/packages/avr-xyz.scm (microscheme): New variable.
> ---
>  gnu/packages/avr-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++++
>  gnu/packages/avr.scm     | 42 +---------------------------------------
>  2 files changed, 42 insertions(+), 41 deletions(-)
> 
> diff --git a/gnu/packages/avr-xyz.scm b/gnu/packages/avr-xyz.scm
> index a05157ede7..771753b5e4 100644
> --- a/gnu/packages/avr-xyz.scm
> +++ b/gnu/packages/avr-xyz.scm
> @@ -28,14 +28,55 @@ (define-module (gnu packages avr-xyz)
>    #:use-module (gnu packages autotools)
>    #:use-module (gnu packages base)
>    #:use-module (gnu packages bash)
> +  #:use-module (gnu packages check)
> +  #:use-module (gnu packages compression)
>    #:use-module (gnu packages avr)
>    #:use-module (gnu packages elf)
>    #:use-module (gnu packages gl)
> +  #:use-module (gnu packages llvm)
>    #:use-module (gnu packages pkg-config)
>    #:use-module (gnu packages ncurses)
>    #:use-module (gnu packages version-control)
> +  #:use-module (gnu packages vim)
>    #:use-module (gnu packages ruby))
>  
> +(define-public microscheme
> +  (package
> +    (name "microscheme")
> +    (version "0.9.4")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/ryansuchocki/microscheme")
> +             (commit (string-append "v" version))))
> +       (sha256
> +        (base32 "1bflwirpcd58bngbs6hgjfwxl894ni2gpdd4pj10pm2mjhyj5dgw"))
> +       (file-name (git-file-name name version))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:parallel-build? #f             ; fails to build otherwise
> +       #:tests? #f                      ; no tests
> +       #:phases
> +       (modify-phases %standard-phases
> +         (delete 'configure))
> +       #:make-flags
> +       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))))
> +    (native-inputs
> +     (list clang cppcheck unzip xxd))
> +    (home-page "https://github.com/ryansuchocki/microscheme/")
> +    (synopsis "Scheme subset for Atmel microcontrollers")
> +    (description
> +     "Microscheme, or @code{(ms)} for short, is a functional programming
> +language for the Arduino, and for Atmel 8-bit AVR microcontrollers in general.
> +Microscheme is a subset of Scheme, in the sense that every valid @code{(ms)}
> +program is also a valid Scheme program (with the exception of Arduino
> +hardware-specific primitives).  The @code{(ms)} compiler performs function
> +inlining, and features an aggressive tree-shaker, eliminating unused top-level
> +definitions.  Microscheme has a robust @dfn{Foreign Function Interface} (FFI)
> +meaning that C code may be invoked directly from (ms) programs.")
> +    (license license:expat)))
> +
>  (define-public simavr
>    (package
>      (name "simavr")
> diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
> index e976203b89..ccce686010 100644
> --- a/gnu/packages/avr.scm
> +++ b/gnu/packages/avr.scm
> @@ -32,12 +32,9 @@ (define-module (gnu packages avr)
>    #:use-module (guix build-system gnu)
>    #:use-module (guix build-system trivial)
>    #:use-module (gnu packages check)
> -  #:use-module (gnu packages compression)
>    #:use-module (gnu packages cross-base)
>    #:use-module (gnu packages flashing-tools)
> -  #:use-module (gnu packages gcc)
> -  #:use-module (gnu packages llvm)
> -  #:use-module (gnu packages vim))
> +  #:use-module (gnu packages gcc))
>  
>  (define-public avr-binutils
>    (package
> @@ -142,40 +139,3 @@ (define-public avr-toolchain
>  C++.")
>      (home-page (package-home-page avr-libc))
>      (license (package-license avr-gcc))))
> -
> -(define-public microscheme
> -  (package
> -    (name "microscheme")
> -    (version "0.9.4")
> -    (source
> -     (origin
> -       (method git-fetch)
> -       (uri (git-reference
> -             (url "https://github.com/ryansuchocki/microscheme")
> -             (commit (string-append "v" version))))
> -       (sha256
> -        (base32 "1bflwirpcd58bngbs6hgjfwxl894ni2gpdd4pj10pm2mjhyj5dgw"))
> -       (file-name (git-file-name name version))))
> -    (build-system gnu-build-system)
> -    (arguments
> -     `(#:parallel-build? #f             ; fails to build otherwise
> -       #:tests? #f                      ; no tests
> -       #:phases
> -       (modify-phases %standard-phases
> -         (delete 'configure))
> -       #:make-flags
> -       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))))
> -    (native-inputs
> -     (list clang cppcheck unzip xxd))
> -    (home-page "https://github.com/ryansuchocki/microscheme/")
> -    (synopsis "Scheme subset for Atmel microcontrollers")
> -    (description
> -     "Microscheme, or @code{(ms)} for short, is a functional programming
> -language for the Arduino, and for Atmel 8-bit AVR microcontrollers in general.
> -Microscheme is a subset of Scheme, in the sense that every valid @code{(ms)}
> -program is also a valid Scheme program (with the exception of Arduino
> -hardware-specific primitives).  The @code{(ms)} compiler performs function
> -inlining, and features an aggressive tree-shaker, eliminating unused top-level
> -definitions.  Microscheme has a robust @dfn{Foreign Function Interface} (FFI)
> -meaning that C code may be invoked directly from (ms) programs.")
> -    (license license:expat)))
> -- 
> 2.34.1
> 
> 
>
Maxim Cournoyer Oct. 5, 2023, 4:19 a.m. UTC | #2
Hi,


Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com> writes:

> * gnu/packages/avr.scm (microscheme): Remove from file.
>
> * gnu/packages/avr-xyz.scm (microscheme): New variable.

Nitpicks: I'd drop the separating blank line and reword to:

--8<---------------cut here---------------start------------->8---
* gnu/packages/avr.scm (microscheme): Move to...
* gnu/packages/avr-xyz.scm (microscheme): ... here.
--8<---------------cut here---------------end--------------->8---
diff mbox series

Patch

diff --git a/gnu/packages/avr-xyz.scm b/gnu/packages/avr-xyz.scm
index a05157ede7..771753b5e4 100644
--- a/gnu/packages/avr-xyz.scm
+++ b/gnu/packages/avr-xyz.scm
@@ -28,14 +28,55 @@  (define-module (gnu packages avr-xyz)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
+  #:use-module (gnu packages check)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages avr)
   #:use-module (gnu packages elf)
   #:use-module (gnu packages gl)
+  #:use-module (gnu packages llvm)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages version-control)
+  #:use-module (gnu packages vim)
   #:use-module (gnu packages ruby))
 
+(define-public microscheme
+  (package
+    (name "microscheme")
+    (version "0.9.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ryansuchocki/microscheme")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "1bflwirpcd58bngbs6hgjfwxl894ni2gpdd4pj10pm2mjhyj5dgw"))
+       (file-name (git-file-name name version))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:parallel-build? #f             ; fails to build otherwise
+       #:tests? #f                      ; no tests
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))))
+    (native-inputs
+     (list clang cppcheck unzip xxd))
+    (home-page "https://github.com/ryansuchocki/microscheme/")
+    (synopsis "Scheme subset for Atmel microcontrollers")
+    (description
+     "Microscheme, or @code{(ms)} for short, is a functional programming
+language for the Arduino, and for Atmel 8-bit AVR microcontrollers in general.
+Microscheme is a subset of Scheme, in the sense that every valid @code{(ms)}
+program is also a valid Scheme program (with the exception of Arduino
+hardware-specific primitives).  The @code{(ms)} compiler performs function
+inlining, and features an aggressive tree-shaker, eliminating unused top-level
+definitions.  Microscheme has a robust @dfn{Foreign Function Interface} (FFI)
+meaning that C code may be invoked directly from (ms) programs.")
+    (license license:expat)))
+
 (define-public simavr
   (package
     (name "simavr")
diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
index e976203b89..ccce686010 100644
--- a/gnu/packages/avr.scm
+++ b/gnu/packages/avr.scm
@@ -32,12 +32,9 @@  (define-module (gnu packages avr)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
   #:use-module (gnu packages check)
-  #:use-module (gnu packages compression)
   #:use-module (gnu packages cross-base)
   #:use-module (gnu packages flashing-tools)
-  #:use-module (gnu packages gcc)
-  #:use-module (gnu packages llvm)
-  #:use-module (gnu packages vim))
+  #:use-module (gnu packages gcc))
 
 (define-public avr-binutils
   (package
@@ -142,40 +139,3 @@  (define-public avr-toolchain
 C++.")
     (home-page (package-home-page avr-libc))
     (license (package-license avr-gcc))))
-
-(define-public microscheme
-  (package
-    (name "microscheme")
-    (version "0.9.4")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/ryansuchocki/microscheme")
-             (commit (string-append "v" version))))
-       (sha256
-        (base32 "1bflwirpcd58bngbs6hgjfwxl894ni2gpdd4pj10pm2mjhyj5dgw"))
-       (file-name (git-file-name name version))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:parallel-build? #f             ; fails to build otherwise
-       #:tests? #f                      ; no tests
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))
-       #:make-flags
-       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))))
-    (native-inputs
-     (list clang cppcheck unzip xxd))
-    (home-page "https://github.com/ryansuchocki/microscheme/")
-    (synopsis "Scheme subset for Atmel microcontrollers")
-    (description
-     "Microscheme, or @code{(ms)} for short, is a functional programming
-language for the Arduino, and for Atmel 8-bit AVR microcontrollers in general.
-Microscheme is a subset of Scheme, in the sense that every valid @code{(ms)}
-program is also a valid Scheme program (with the exception of Arduino
-hardware-specific primitives).  The @code{(ms)} compiler performs function
-inlining, and features an aggressive tree-shaker, eliminating unused top-level
-definitions.  Microscheme has a robust @dfn{Foreign Function Interface} (FFI)
-meaning that C code may be invoked directly from (ms) programs.")
-    (license license:expat)))